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Tips and Tricks with Excel
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Add a carriage return to a cell’s contents

• Problem: You need to enter a long text to a cell, each time you press Enter 
to separate lines, Excel just takes you to a new cell.

• Solution: 
• PC: press Alt-Enter at the end of a line

• MAC: press Command-Option Enter at the end of a line
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Get rid of spaces

• TRIM()
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Symbol changed by Excel 
Unintended format

• Cause:
Excel automatically applies a built-in 

number format to a cell, based on the 
following criteria: 

• If a number contains month JAN to 
DEC, it may be converted to a date 
format. 

• If a number contains the letter E (in 
uppercase or lowercase letters; for 
example, 10e5), or the number 
contains more characters than can be 
displayed based on the column width 
and font, the number may be 
converted to scientific notation, or 
exponential, format. 

• If a number contains leading zeros, the 
leading zeros are dropped.
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Symbol changed by Excel: Solution

1. Before you populate the data into excel, select the cells that will contain 
the numbers stored as text

2. Right-click and choose Format Cells >Text > OK
3. If a symbol is copied from an website, you may need to use Paste Special 

> Text or Unicode Text
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Highlight duplicated cells

• Highlight the region that may 
have duplicated values

• Format >

conditional formatting

• Formula Is: 
• =COUNTIF (region, cell)>1

• Region: absolute rows and 
columns

• $C$2:$C$15 

• Active cell: relative reference
• C2

Maintain the position(s) of cell(s) in a 

formula: 

Prefix "$" to create an absolute link
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Highlight duplicated cells

• Format > Patterns > choose color > OK
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Remove duplicated records

• Data > Filter > Advanced Filter > Unique records only
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Move to the last row in a list

• PC: 
• First cell in the active column: Ctrl +  up arrow
• Last cell in the active column:  Ctrl + down arrow
• First cell in the active row:       Ctrl + left arrow
• Last cell in the active row:       Ctrl + right arrow
• The very first cell (A1): Ctrl+ Home
• Bottom right corner: Ctrl+ End

• MAC: 
• use either Command or Control
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Selecting a Range of Cells

•Selecting a large range of cells can be a pain.  Here’s 
one trick that could help.

• To start the selection of a large matrix, start by selecting the 
bottom right cell of the desired matrix (Ctrl + End)

• Use "Ctrl + Shift + up arrow" to select everything above the 
original cell. 

• Use "Ctrl + Shift + left arrow" to select everything to the left 
of the original cell. 

• Use "Shift + down arrow" to move down one row (to avoid 
the header line, if present). 

• Use "Shift + right arrow" to move to the right one column 
(to avoid any ID column(s), if present)
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Keep headers constant as you scroll

• Click the first cell in the row below the last row you want to freeze

• Choose Window > Freeze Panes

• To unfreeze frozen rows, choose Window > Unfreeze Panes
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To freeze rows and columns along the top and 
left edges as you scroll

• Click the cell below and to the right of the rows and columns 
you want to freeze

• Window > Freeze Panes
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Sort by more than 3 columns

If you want to sort by columns A B C D E, select the whole 
spreadsheet, than sort by C D E, than A B.  This will result in all 
five columns being sorted.
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About Formula

Problem: values changed due to an extra column inserted

Solution: Copy →Paste Special→Values



vlookup
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Look up values in data list: vlookup

• VLOOKUP(lookup_value,table_array,col_index_num,
not_exact_match)

• lookup_value :The value to search in the first column of the 
table array

• table_array:  The table to search (containing the value to 
search for in the first column) 

• col_index_num: the column number from which the 
matching value is returned 

• not_exact_match:
• True/omitted, an exact/approximate match

• False: an exact match
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Vlookup example 

Too complicated? 

Try BaRC Submatrix Selector

http://iona.wi.mit.edu/bell/submatrix_selector
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Macro
• Record macro

• Stop Recording macro
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Run macro



Task one

• Open a new page in Microsoft Excel.

1. Enter this data as shown in the right 
cells.

2. We are going to make up some 
Multiplication tables. Click on cell B2.

3. Enter the number 7

4. Highlight the column from B2 to B13

5. On the Menu bar. Select: Edit – Fill –
Down. The whole column will fill with 7’s.

6. Click on cell C2. We are going to enter 
the calculation.

What do we need to enter first?



Task one
=a2*b2

This is because these are the cells with 

the numbers we want to multiply.

Note want happens when you enter the 

formula.

Now use the same method that you used 

to FILL column B with 7’s to repeat the 

formula in column C.

Can you remember how?



Task one
If you have done it right, which you 

will have done!

Your spreadsheet should look like this.

Task Two:

In a new spreadsheet, can you create 

the 8x table using the techniques we

have learned so far.



Task Three

• PE Kit

• You receive a letter from your teacher. It tells you what PE you 

• need for the new term.

• You need:

• 2 T-shirts, 2 pairs of shorts, 2 pairs of socks, a pair of trainers for 

• outdoors and a pair of plimsolls for indoors

Open a new document and enter this information 
into the correct cells.



Task Three

With the information shown above you can calculate the cost of you new PE Kit for 
yourself.

Fill in cells D2, D3, D4, D5 and D6.

Now select cell D7 and click on this symbol on the toolbar         . Press RETURN and the 
column total appears

Use multiplication to fill column E and F, and use          to total up the columns.



Task four
• Creating Graphs

• You can use spreadsheets to create graphs of your data.

• Of course you will need some data to make graphs of!

Open a new spreadsheet and 
set up the columns and rows as 
shown here.

Now you need to find out how 
many boys and how many girls 
are in each year group. 

Find out and enter the data.

In column D use a formula to 
add up the totals.

Click on B10

Then click on        on the 
toolbar. 



Task four

• Creating Graphs

• This tool        allows you to add up column totals.
Click on B3, hold down the shift 
key and click on B8.

The column total should appear in 
B10.

Use this method to complete the 
rest of this spreadsheet.

Now you are ready to create a 
graph!

It is easy – but watch carefully!!



Task four
1. Select the data you are going to 

graph.

2. Now you are ready to create a 
graph! Find this icon and click it.

3. Select the column graph and click 
NEXT.

4. Click the ‘Series’ tab. Change each 
series, Series 1 – Boys, Series 2 –
Girls, and Series 3 – Total.

5. Click NEXT and give your chart a 
title and label the X and Y axis.

6. Click NEXT, choose to place chart 
in new sheet, then click FINISH.

7. Now you can print your chart.

It’s that simple!!



Functions for Descriptive Statistics

• Your Excel spreadsheet 
should now look like 
this:



Part 2: Correlations and Scatterplots



Correlations

A quick review:

• Every correlation has a direction (positive or 
negative):

• + correlation: high scores on one variable are associated with high scores on 
another variable.

• - correlation: high scores on one variable are associated with low scores on 
the other variable.

• Every correlation has a magnitude or strength:
• The closer the correlation coefficient is to +1.00 or -1.00, the stronger it is.

• The closer the correlation coefficient is to 0.00, the weaker it is.



Calculating Pearson’s r

• Correlations are described using the Pearson Product-
Moment correlation statistic, or r value.

• In Excel, there are many functions that can  calculate a 
correlation statistic, however, we will only use 
=PEARSON in this class.

Let’s say we want to determine if there is a 
relationship between number of hours spent per week 
studying for Psych 209 and GPA earned in the class at 
the end of the quarter. To do so, we can calculate 
Pearson’s r for our two variables.



Enter the following data into Excel:

StudyHrs = average number of hours spent per week studying for 209 

GPA = grade-point average earned in 209 at the end of the quarter



Step 1: Select the cell where you want your r
value to appear (you might want to label it).

Step 2: Click on the function wizard      button.

Step 3: Search for and select PEARSON.



Step 4: For Array1, select all the values under StudyHrs.

For Array2, select all the values under GPA.



Step 5: That’s it! Once you have your r value, don’t 
forget to round to 2 decimal places.

Knowledge check: What does the r value of 0.88 tell you about 

the strength and direction of the correlation between StudyHrs 

and GPA?



Scatterplots

• A scatterplot is an excellent way to visually display the relationship 
(correlation) between two variables.

• Each point on the scatterplot represents an individual’s data on the 
two variables.

• We will now create a scatterplot for StudyHrs and GPA. 



Step 1: Select both columns of variables you wish to 
plot (StudyHrs and GPA).

Step 2: Click on the tab labeled ‘Insert’, and then 
select ‘Scatter’ in the ‘Charts’ menu.



Step 3: Select the first plot in the drop-down menu.



Step 4: Remove the legend by clicking on it and 
pressing Delete.



Step 5: Add axis titles by selecting the ‘Layout’ tab and 
clicking on ‘Axis Titles.’ For the horizontal title, you want it 
below the x-axis. For the vertical title, you want the 
‘Rotated Title’ option. 

NOTE: Your chart 

must be 

highlighted for 

the ‘Layout’ tab to 

appear under 

‘Chart Tools.’



• For scatterplots, it does not matter which variable goes 
on each axis (this is NOT true for other types of charts).

• However, you need to make sure you label your axes 
with the proper variable name.

• In this example, GPA is on the y-axis and Study Hours is 
on the x-axis (we can tell this based on their different 
ranges of values).

• As a helpful hint, Excel will automatically put the first 
variable (left-hand column) on the x-axis, and the 
second variable (right-hand column) on the y-axis.

A note about x- and y-axes:



Step 6: Change the chart title by selecting it, typing a new 
one, and pressing Enter. Chart and axis titles may be 
altered by right-clicking on them.  



Your scatterplot is now finished!  

Remember: Each point in the scatterplot represents an 

individual’s data.

Knowledge check: Identify Student 8 in the scatterplot.



Describing Correlations and 
Scatterplots

 Scatterplots and correlations are described:

 As positive or negative.  

 As weak, moderate, or strong.

 Using the r value.

 Sentence 1: There is a strong, positive correlation (r = 0.88) 

between the number of hours studied and GPA.

 Then you want to describe the general relationship 

between the two variables: 

 Sentence 2: More hours of studying for Psych 209 was 

associated with a higher GPA earned in the class at the end of 

the quarter.

 NOTE: We cannot say “More studying led to a higher 

GPA” – this implies causation, which cannot be 

determined using correlational research.


