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1. Understanding Databases
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Key Concepts

❑ Understand what a database is.

❑ Understand the difference between data and information.

❑ Understand how a database is organized in terms of tables, 

records and fields.

❑ Know some of the common uses of large-scale databases.
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What is a database?

A database is defined as an organized collection of data (information).
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Data & Information

Data is information converted into binary digital form.

Information is facts or details about sb/sth.

Data

Information

6



File and Database Concepts

• A database is a collection of information
• Databases are typically stored as computer files

• A structured file is similar to a card file or Rolodex because it uses a 
uniform format to store data for each person or thing in the file



Database Organization

Database

Fields

Records

Tables

data about one or more subjects.
D A structured collection of related
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Database Uses

Airline booking systems.

Government records.

Bank account records.

Hospital patient details.
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Database Organization

❑ Understand that each table in a database should contain data 

related to a single  subject type.

❑ Understand that each field in a table should contain only one 

element of data.

❑ Understand that field content is associated with an 

appropriate data.

❑ Understand that fields have associated field properties.

❑ Understand what a primary key is.

❑ Understand what an index is.
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Table
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A table is a list of information organized into columns and rows.

In the example of a client contact database, the table might list the names,  

addresses, phone numbers, company names, titles, and e-mail addresses of  

your clients.

You can have numerous tables in your Access database.



Table Field

• Fields are the individual items that make up a 
record within your database.

• A field contains the smallest unit of meaningful 
information
• Each field has a unique field name that describes its 

contents

• A field can be either variable length or fixed length. 

• A record is a collection of information that 
relates to a particular item within  your 
database table.
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File and Database Concepts

Student Information

ID Number

Last Name

First Name

Email

Address

City

Program

Sponsor ID Number

Sponsor 

Information

Sponsor ID Number

Company Name

Contact Last Name

Contact First Name

Email

Telephone

Fax Number

Address

City

Course Information

Course ID Number

PeopleSoft ID Number

Course Name

Instructor ID Number

Instructors

Instructor ID Number

Last Name

First Name

Faculty

Email

Office Telephone

Financial Accounts

Student ID Number

Term Number

Cost Per Course

Number of Courses

Amount for Term

Amount Paid

Amount Owing

Faculty Advisors

Student ID Number

Instructor ID Number

Possible Tables in a School Database:



Basic Types
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Format Use to display

Text Short, alphanumeric values, such as a last name or a street address.

Number Numeric values, such as distances.

Currency Monetary values.

Yes/No Yes and No values and fields that contain only one of two values.

Date/Time Date and Time values for the years 100 through 9999.

Attachment Attached images, spreadsheet files, documents, charts, and other types of supported files to

the records in your database, similar to attaching files to e-mail messages.

Hyperlink Text or combinations of text and numbers stored as text and used as a hyperlink address.

Memo Long blocks of text. A typical use of a Memo field would be a detailed product description.

Lookup Displays either a list of values that is retrieved from a table or query, or a set of values that  

you specified when you created the field.



Field Properties
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Property Use

Filed Size Field Size sets the maximum space available for any one value.

Caption The label text that is displayed for this field by default in forms, reports, and  

queries. If this property is empty, the name of the field is used.

Required Requires that data be entered in the field.

Format choose a format that meets your specific needs.

Indexed Yes (No duplicates) Creates a unique index on the field.

Yes (Duplicates OK) Creates a non-unique index on the field.  

No Removes any index on the field.

Default Value Automatically assigns the specified value to this field when a new record  

is added.

Validation Rule Supplies an expression that must be true whenever you add or change the  

value in this field. Use in conjunction with the Validation Text property.

Validation Text Enter a message to display when a value that is entered violates the

expression in the Validation Rule property.



Primary Key
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A primary key field is one that uniquely identifies each individual record in a  

table.

When choosing a primary key, keep the following rules in mind:

The primary key values must be unique.

A primary key value can't be null. Within this context, null means an empty field.

The primary key must exist when the record is created and stored.

1. Primary key

2. Foreign key

(key in 

another

table)



Indexed Field
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You can use an index to help Access find and sort records faster.

An index stores the location of records based on the field or fields that are  

part of the index.

A database index is, after all, very much like the index at the end of a book:  

it occupies its own space, it is highly redundant, and it refers to the actual  

information stored in a different place.



Relationships

❑ Understand that the main purpose of relating tables in a

database.

❑ Understand how a relationship is built.

❑ Understand the importance of maintaining the integrity 

of  relationships between tables.

❑ Understand the cardinality of relationships
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Purpose of Relationships

• The main purpose of relating tables in a database is to 

minimize duplication of data.
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Relationship Establishment
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A relationship is built by matching a unique field in one table with a field in

another table.



Relationships Integrity
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Referential integrity rules keep database users from accidentally breaking the

mapping between related columns.



Cardinality

• Cardinality refers to the number of associations that can exist 
between two record types

• A one-to-one relationship means that a record in one record type is 
related to only one record in another record type

• Example:
• A single grade report is related to only one student.

• When one record is related to many records in another table, the 
relationship is referred to as a one-to-many relationship
• Example:

• Instructor records to student advisees



Cardinality

• A many-to-many relationship means that one record in a particular 
record type can be related to many records in another record type, 
and vice versa

• Example:
• Student records to course enrollment



Operations

❑ Define which various functions that allow management of a

database.

❑ Classify three main functional groups which are related to the

database.
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Operation
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Professional databases are designed and created by database specialists.

Data entry, data maintenance and information retrieval are carried out by  

users.

A database administrator provides access to specific data for appropriate

users.

Database administrator is responsible for recovery of a database after a crash  

or major errors.



2. Using the Application
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Working with Databases
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❑ Open, close a database application.

❑ Open, close a database.

❑ Create a new database and save to a location on a drive.

❑ Use available Help functions.



1. Start Access.

2. On the New tab in Backstage view,

click Blank Database or Blank Web

Database.

3. On the right, type a name for your

database in the File Name box.

4. Click Create.

2
4
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Create a new database



1. On the File tab, click Open.

2. Click a shortcut in the Open dialog  

box — or, in the Look in box, click  

the drive or folder that contains  

the database that you want.

3. In the folder list, double-click  

folders until you open the folder  

that contains the database.

25
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Open an existing database



Common Tasks
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❑ Open, save and close a table, query, form, report.

❑ Switch between view modes in a table, query, form, report.

❑ Delete a table, query, form, report.

❑ Navigate between records in a table, query, form.

❑ Sort records in a table, form, query output



1. Once you have your database  open, go to the 

target object you  want to deal with 

(Customers  table, for instance)

2. Double-Click the table name to

open and view its content.

3. Modify within the table entries and

click Save to confirm your changes.

4. Close the table by Clicking on the  close button in 

the upper right  corner.

3

4
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Open/Save/Close a database object
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3. Click Datasheet/Design View.

2
8

1. Click the Home tab on the Ribbon.

2. Click the bottom half of the View

button.

1

2

3

Switch Views



1. Click the database object you want  

to remove to select.

2. Click the Delete Button from the  

Home Ribbon.
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Delete database objects



1. In the Navigation pane, double-

click the table/Query/form whose  

records you want to navigate.

2. Click Previous Record or Next  

Record to move back or  

forward by one record.

3. Access displays the previous or

next record in the database.

4. Click First Record or Last

Record to navigate to the first

to

or last record in the table.

5. Click New (Blank) Record

start a new, blank record.

30

1
4 52243

Navigate Records



1. Open the table you want to sort.

2. Position your mouse pointer over  

the column header for the field by  

which you want to sort.

3. Click the Home tab on the Ribbon.

4. Click a sort button.

• Click Ascending to sort the records  

in ascending order.

• Click Descending to sort the

records in descending order.

31
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3. Tables
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Records
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❑ Add, delete records in a table.

❑ Add, modify, delete data in a record.



1. In the Navigation pane, double-

click the table to which you want  

to add a record.

2. Type the desired data in the  

selected cell.

• Press [Tab]

3. Repeat Step 2 until you have filled  

the entire row.

4. Press [Enter] to move to the next

row, or record.

3
4

Add/Delete Records
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If the table is still in design view, click  

View/Datasheet View. If it's closed,  

double-click the table in the Database  

window.

1. Once the table is in Datasheet view  

mode, you can add a new record.

2. To modify a value, select the appropriate  

field and replace the value.

3. To delete a value, select it and press Delete.

35

Add/Delete Records
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Design
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❑ Create and name a table and specify fields with their data types

❑ Apply field property settings

❑ Create a validation rule

❑ Understand consequences of changing data types, field properties in a table.

❑ Set a field as a primary key.

❑ Index a field

❑ Add a field to an existing table.

❑ Change width of columns in a table.



1. On the Create tab, in the Tables group,

click Table.

2. A new table is inserted in the database and  

the table opens in Datasheet view.

3. On the Home tab, in the Views group,

click View, and then click Design View.

4. Give a name to the table and save its current

structure.

5. In the Field Name column, enter the name of  

the field that you want to create.

6. In the Data Type column, select the appropriate

type for the corresponding field.

3
7

Create a table with fields
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1. In the table design grid, select the field for  

which you want to set properties. Access  

displays the properties for this field in the Field  

Properties pane.

2. In the Field Properties pane, enter the settings

that you want for each property, or press F6 and

then use the arrow keys to select a property.

38

Apply field property settings

1

2



1. In the Navigation Pane, right-click the table  

that you want to change, and then

click Design View.

2. In the Field Name column, select the field  

that you want to change.

3. In the lower section of the table designer, on  

the General tab, select the Validation

Rule property box, and then enter your

validation rule.

39

Create a validation rule
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Validation rule Validation text

<>0 Enter a nonzero value.

>=0 You must enter a positive number.

0 or >100 Value must be either 0 or greater than 100.

BETWEEN 0 AND 1 Enter a value with a percent sign.

<#01/01/2007# Enter a date before 2007.

>=#01/01/2007# AND <#01/01/2008# Date must occur in 2007.

IN (" Tokyo", "Paris", "Moscow ") Tests for values equal to existing members in a list.

IS NOT NULL Forces users to enter values in the field.

Examples of Validation Rules
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You can change most data types  

when a field contains data.

Access might truncate or delete  

some data, or it may not allow the  

conversion at all.

Convert to this type From this type Changes or restrictions

Text Memo Access deletes all but the first 255 characters.

Number Text Text must consist of numbers and valid  

currency and decimal separators.

Date/Time Text Original text must be a recognizable date or  

date-time combination. For example, 18-Jan-

2006.

Examples of Restrictions on changing data types

Consequences of changing data types, field
properties

45



3. Select the field or fields that you want to use  

as the primary key.

4. On the Design tab, in the Tools group,  

click Primary Key.

4
2

Set a field as a primary key
1. Open the database that you want to modify.

2. In the Navigation Pane, right click the table in

which you want to set the primary key and, on

the shortcut menu, click Design View.

1
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1. In the Navigation Pane, right-click the

name of the table that you want to create 4.
the index in, and then click Design

View on the shortcut menu.

3. Under Field Properties, click the General tab.

In the Indexed property, click Yes (Duplicates OK) if  

you want to allow duplicates, or Yes (No  

Duplicates) to create a unique index.

5. To save your changes, click Save on the Quick  

Access Toolbar, or press CTRL+S.

Index a field

1

2

3

4

2. Click the Field Name for the field that  

you want to index.

5
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1. Double-click to open the table to which  

you want to add a field in Datasheet  

view.

2. Click the column heading to the left of  

where you want to insert a new field.

3. Access adds the column for the new field to

the right of the column you select.

4. Click the Fields tab.

5. In the Add & Delete group, click the button  

for the type of field you want to add.

4
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Add a field to an existing table

1

2

3

4

5



1. Rest the cursor on right side of the column  

boundary you want to move until it becomes a  

resize cursor

2. Drag the boundary until the column is the

width you want.
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Change width of columns

1 2



4. Retrieving Information
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Main Operations
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❑ Use the search command for a specific word, number, date in a field.

❑ Apply a filter to a table, form.

❑ Remove the application of a filter from a table, form.



1. Open the table or form, and then click the field 4.

that you want to search.

2. On the Home tab, in the Find group, click Find,

To change the field that you want to search or to  
search the entire underlying table, click the  
appropriate option in the Look In list.

5. In the Search list, select All, and then click
Find Next.

6. When the item for which you are searching is  
highlighted, click Cancel in the Find and
Replace dialog box to close the dialog box. Records
that match your conditions are highlighted

4
8

Use the search command

or press CTRL+F.

The Find and Replace dialog box appears, with
the Find tab selected.

3. In the Find What box, type the value for which  
you want to search.
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1. In the Navigation pane, double-click the  

table/form you want to use to filter records.

2. Click in the Home tab.

3. Click the Selection Button.

4. Click a criterion.

5. You can use the navigation buttons < |< > and >|

to view the filtered records.

6. To remove the filter, you can click the Toggle  

Filter button.

4
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Apply a simple filter
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1. In the Navigation pane, double-click the  

table/form you want to use to sort records.

2. Click in the Home tab.

3. Click the Advanced Button.

4. Click Filter By Form.

5. Click in the field by which you want to filer.

6. Click the v that appears and choose a criterion.

7. Repeat steps 5 and 6 to add more criteria to the filter

8. Click the Toggle Filter button to filter the records.

9. Click the Toggle Filter button again to remove the  

filter.

5
0

Filter by Form
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Queries

❑ Understand that a query is used to extract and analyze data.

❑ Create a named single table query using specific search
criteria.

❑ Create a named two-table query using specific search criteria.

❑ Add criteria to a query.

❑ Add criteria to a query using logical operators

❑ Use a wildcard in a query

❑ Edit a query: add, modify, remove criteria.
❑ Edit a query: add, remove, move, hide, unhide fields.

❑ Run a query.



Query Overview

• A select query is a database object that shows information in 

Datasheet view.

• A query does not store data, it displays data that is stored in

tables.

• A query can show data from one or more tables, from other 
queries, or from a combination of the two.

• A query lets you:
• View data only from the fields you are interested in viewing.

• Combine data from several data sources.

• Use expressions as fields.

• View records that meet criteria that you specify.

5
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On the Create tab, in the Other group,  

click Query Wizard.

In the New Query dialog box, click Simple  

Query Wizard, and then click OK.

5
3

Next, you add fields.

For each field, perform these two steps:

Under Tables/Queries, click the table or query that  

contains the field.

Under Available Fields, double-click the field to add  

it to the Selected Fields list.

When you have added all the fields that you want,  

click Next.

Use the query wizard



Add criteria to the query

• If necessary, double-click the 
query in the  Navigation pane 
that you want to modify to  open 
it.

• Click the Home tab.

• Click the bottom half of the View 
button

• Click Design View

• Click the Criteria box for the field 
you want to use  as a criterion 
and type the data that you want 
to  view.

• Click the bottom half of the View 
button

• Click Datasheet View
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5. Objects
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6. Outputs
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