
ICDL Module 5:
Databases

using

OpenOffice.org
Base

David Varley

IMPORTANT NOTICE

All candidates who follow an ICDL/ECDL course must have an official CDL/ECDL 
Skills Log Book or Skills Card.  Without such a Log Book or Skills Card no tests can 

be taken and the candidate will not be able to obtain an International Computer 
Driving Licence, nor any other form of certificate or recognition for the course.

 Log Books/Skills Cards are obtainable from ICDL/ECDL Training and Testing Centres 
(see www.icdl.org.za) or directly from the ICDL Foundation of South Africa.   

(info@icdl.org.za, phone +27-21-671-1071)

mailto:info@icdl.org.za


© ICDL Foundation 2006

Second Edition November 2005

Illustrations, design and typography by David Varley

ISBN to follow

This work is licensed under the Creative Commons Attribution-NoDerivs 2.5 License. To view a 
copy of this license, visit http://creativecommons.org/licenses/by-nd/2.5/ or send a letter to 
Creative Commons, 543 Howard Street, 5th Floor, San Francisco, California, 94105, USA.  First 
published 2004.

“European Computer Driving Licence” and ECDL and Stars device are registered trade marks of 
the European Computer Driving Licence Foundation Limited in Ireland and other countries.

Neither the European Computer Driving Licence Foundation nor the ICDL Foundation warrants 
that the use of this product will ensure passing the relevant examination. Use of the ECDL-F 
approved Courseware Logo on this product signifies that it has been independently reviewed 
and approved in complying with the following standards: Acceptable coverage of all courseware 
content related to ECDL Syllabus Version4. This courseware material has not been approved for 
technical accuracy and does not guarantee that the end user will  pass the associated ECDL 
Examinations. Any and all assessment tests and/or performance based exercises contained in 
this (publication, CD, etc.) relate solely to this (publication, CD, etc.) and do not constitute, or 
imply, certification by the European Computer Driving Licence Foundation Limited in respect of 
any  ECDL Examinations.  For  details  on  sitting  ECDL Examinations  in  your  country  please 
contact the local ECDL Licensee or visit the European Computer Driving Licence Foundation 
Limited web site at http://www.ecdl.com.

Published by the ICDL Foundation of South Africa
G1 Greenford Office Estate
Punters Way
Kenilworth, 7708, South Africa

Telephone: +27 (0)21 671 1071
Fax: +27 (0)21 671 1125



Syllabus

Module 5: Databases

5.1 Using the Application

5.1.1 Database Concepts
5.1.1.1 Understand what a database is.
5.1.1.2 Understand how a database is organised in terms of tables, records, 

fields, and with field data types, field properties.
5.1.1.3 Understand what a primary key is.
5.1.1.4 Understand what an index is.
5.1.1.5 Understand the purpose of relating tables in a database.
5.1.1.6 Understand the importance of setting rules to ensure relationships 

between tables are valid.
5.1.2 First Steps with Databases
5.1.2.1 Open (and close) a database application.
5.1.2.2 Open, log onto an existing database.
5.1.2.3 Create a new database.
5.1.2.4 Save a database to a location on a drive.
5.1.2.5 Use available Help functions.
5.1.2.6 Close a database.
5.1.3 Adjust Settings
5.1.3.1 Change between view modes in a table, form, report.
5.1.3.2 Display, hide built-in toolbars.

5.2 Tables

5.2.1 Main Operations
5.2.1.1 Create and save a table and specify fields with their data types.
5.2.1.2 Add, delete records in a table.
5.2.1.3 Add a field to an existing table.
5.2.1.4 Add, modify data in a record.
5.2.1.5 Delete data in a record.
5.2.1.6 Use the undo command.
5.2.1.7 Navigate within a table to next record, previous record, first record, 

last record, specific record.
5.2.1.8 Delete a table.
5.2.1.9 Save and close a table.
5.2.2 Define Keys
5.2.2.1 Define a primary key.
5.2.2.2 Index a field with, without duplicates allowed.
5.2.3 Table Design/Layout
5.2.3.1 Change field format attributes such as: field size, number format, 

date format.
5.2.3.2 Understand consequences of changing field size attributes in a table.
5.2.3.3 Create a simple validation rule for number, text, date/time, currency.
5.2.3.4 Change width of columns in a table.
5.2.3.5 Move a column within a table.
5.2.4 Table Relationships
5.2.4.1 Create a one-to-one, one-to-many relationship between tables.
5.2.4.2 Delete relationships between tables.
5.2.4.3 Apply rule(s) to relationships such that fields that join tables are not 

deleted as long as links to another table exist.

5.3 Forms

5.3.1 Working with Forms
5.3.1.1 Open a form.
5.3.1.2 Create and save a form.



5.3.1.3 Use a form to enter, modify, delete records.
5.3.1.4 Go to next record, previous record, first record, last record, 

specific record using form display.
5.3.1.5 Add, modify text in Headers, Footers in a form.
5.3.1.6 Delete a form.
5.3.1.7 Save and close a form.

5.4 Retrieving Information

5.4.1 Main Operations
5.4.1.1 Use the search command for a specific word, number, date in a field.
5.4.1.2 Apply a filter to a table, form.
5.4.1.3 Remove a filter from a table, form.
5.4.2 Queries
5.4.2.1 Create and save a single table query, two-table query using specific 

search criteria.
5.4.2.2 Add criteria to a query using any of the

following operators: < (Less than), <= (Less than or equals), > (Greater than), 
>= (Greater than or equals), = (Equals), <> (Not equal to), And, Or.

5.4.2.3 Edit a query by adding, removing criteria.
5.4.2.4 Edit a query: add, remove, move, hide, unhide fields.
5.4.2.5 Run a query.
5.4.2.6 Delete a query.
5.4.2.7 Save and close a query.
5.4.3 Sort Records
5.4.3.1 Sort data in a table, form, query output, in ascending, 

descending numeric, alphabetic order.

5.5 Reports

5.5.1 Working with Reports
5.5.1.1 Create and save a report based on a table, query.
5.5.1.2 Change arrangement of data fields and headings within a report layout.
5.5.1.3 Group data under a specific heading (field) in a report in ascending, 

descending order.
5.5.1.4 Present specific fields in a grouped report by sum, minimum, 

maximum, average, count, at appropriate break points.
5.5.1.5 Add, modify text in Headers, Footers in a report.
5.5.1.6 Delete a report.
5.5.1.7 Save and close a report.

5.6 Prepare Outputs

5.6.1 Prepare to Print
5.6.1.1 Preview a table, form, report.
5.6.1.2 Change report orientation: portrait, landscape. Change paper size.
5.6.2 Print Options
5.6.2.1 Print a page, selected record(s), complete table.
5.6.2.2 Print all records using form layout, specific pages using form layout.
5.6.2.3 Print the result of a query.
5.6.2.4 Print specific page(s) in a report, complete report.
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5.1 Using the Application

5.1.1 Database Concepts

5.1.1.1 Understand what a database is.

In an office application suite, the different applications have different areas of focus. In the 
case of word processors, the focus is  on documents. In spreadsheets, the emphasis  is  on 
calculation. In the case of databases, the focus is on working with information.

Data and information

A word that is related to information is data. Data refers to a collection of unorganised facts. A 
collection of data may contain millions of items. When we  make sense out of the data through 
manipulating it in some way, we say that we have information. In other words, information is 
data that has been made intelligible.

Turning data into information

The purpose of a  database system is  to store the data  and turn it  into  information.  This 
involves a number of processes. Some of these are:

• Storage and retrieval.
• Sorting.
• Performing numerical analysis on the data such as counting, averaging and summation.
• Filtering: Selecting on data that satisfies certain criteria.
• Reporting: Producing output in some standardised and readable format.

5.1.1.2 Understand how a database is organised in terms of tables, records, 

fields, and with field data types, field properties.

Data  itself  needs  to  be  stored in  a  standard  way so  that  the  database can  retrieve  and 
manipulate it. There are a number of levels at which we can look at the storage of the data.

A Table is a collection of data related to a single topic and a database is a collection of tables. 
For example, a company human resource database may comprise a number of tables such as 
staff  personal  details,  salary data,  pension data,  dispute  data,  academic,  professional  and 
training data, and medical scheme data.

Note that each table is related to a single topic. Where a table is found to contain data on more 
than one topic, it should be split.

If you studied database theory in depth, you would soon come across  rules which have been 
formulated with the way databases should ideally be constructed. Technically, these are called 
the rules of normalisation. They are beyond the scope of our work.

A table is made up of a number of rows or records. In our examples above, each record or 
row of the staff personal details table would contain data on a specific employee.  

___________________________________________________________________________
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The rows themselves  are made up of  a  number  of  columns or  fields.  The fields  in  this 
example would include items such as name, first name, date of birth, place of birth, id number, 
marital status and so on.

Fields themselves can be of different types depending on the data they contain. In Base, these 
field types are:

• Text: Used for storing ordinary text such as names and addresses. Note that it should also 
be used for  storing  numbers  on which  you will  not  perform arithmetic  operations.  An 
example of the latter would be telephone numbers. 

• Memo: Used for storing large amounts of text. For example, you could store paragraphs or 
whole documents in a memo field.

• Number: Used for storing any type of number. Only use number fields if you might need 
to perform arithmetic on the contents of the field.

• Decimal: Used to store numbers which contain a fractional part.
• Integer: Used to store whole numbers only.
• Date: Used to store dates. Date fields  can have certain types of arithmetic  operations 

performed on them. For example,  if  you subtract  one date from another,  you get  the 
number of days between.

• Boolean: Used to store data which can only assume one of two values. Examples are 
Yes/No, True/False, 1/0.

• Image: Used to store photographs, signatures, etc.

There are a number of further field types as well as refinements of the fields mentioned above, 
but for the time being, the above list provides an idea of how fields can be typed.

5.1.1.3 Understand what a primary key is.

Each record should have one field that is unique and that can be used to distinguish one record 
from another. An example, could be a staff id number. This field is called the primary key.

Recall that each table contains data on a particular topic. To get a complete set of data on any 
individual, we would need to extract data from a number of tables. What we need is some way 
of being able to link the data in one table with the data in another. If we know an employee's 
staff id  number, this can be used to identify the record in each table associated with that 
employee.

5.1.1.4 Understand what an index is.

An index refers to a field on which a database can be sorted. When you create a table, you 
specify whether or nor you wish a field to be indexed. When you do, Base maintains a special 
structure in the background which allows the table to be rapidly sorted based on the indexed 
fields.

If you might sort a table on a field, you should index it. On the other hand, if you have too 
many indexed fields, the action of the database will be slowed down since the more indexed 
fields there are, the more work the database will have to do.

___________________________________________________________________________
Page 5.7



5.1 OpenOffice.org Base: Using the Application
_______________________________________________________________________________________________

5.1.1.5 Understand the purpose of relating tables in a database.

Since each table contains data on only one topic, we need to be able to access corresponding 
data in different tables. This is done by setting up a relationship between tables.

One way of conceptualising this is as follows. Think of each table as having a pointer. This 
pointer marks the currently active record. If we have a table open, then the current record 
displayed is the one being pointed to. As the pointer moves through the records of the current 
table, other pointers move through the corresponding records of the other tables. These are 
open, but are in the background. The process by which this takes place is the relationship that 
is established between the tables.

5.1.1.6 Understand the importance of setting rules to ensure relationships 
between tables are valid.

One  of  the  problems  that  we  have  to  face  when  working  with  tables  that  are  linked  as 
mentioned above is that we might try to enter data that is inconsistent.

To  prevent  this,  we  set  up  integrity  rules.  These  effectively  prevent  us  from  entering 
inconsistent data.

Suppose  two tables  are  linked,  one  aspect  of  referential  integrity  would  prevent  us  from 
entering data into one table which, for some reason, could not be linked with data in another 
table.

Another aspect of referential integrity is  cascading. If a record in one table is deleted, then 
the  corresponding  records  in  the  other  linked  tables  will  also  be  deleted.  This  is  called 
cascading delete. Related to this is the cascaded update. If the data in a field in one table 
that appears in another is altered, then the corresponding field in the other table will also be 
altered.

If we did not have these integrity rules, then very quickly we would have inconsistent data in 
which the same fields in different tables contain different data.

5.1.2 First Steps with Databases

5.1.2.1 Open (and close) a database application.

Open Base under Windows

• Click Start.
• Click Programs.
• Click OpenOffice.org
• Click OpenOffice.org Base

Open Base under Linux

• Click Start Applications.
• Click Office.
• Click Presentations.
• Click OfficeOffice.org Base

___________________________________________________________________________
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Convention

Because  we will  be  making  extensive  use of  the  Menu bar,  we will  make use  of  the 
following convention in using the functions of the menu bar.

• File » Close.

Will mean exactly the same as

• Click File on the Menu bar.
• Click the Close option in the menu.

5.1.2.2 Open, log onto an existing database.

Suppose we have a database with a pathname such as D:\DATABASES\AFRICA (Windows) or 
/DATABASES/AFRICA (Linux):
• Follow the initial steps set out in the previous section.
• You will be prompted for a new or existing database. Check the Existing database radio 

button.
• Click the Open icon.

This will display the Open File dialogue. This dialogue is shown below for Windows systems. 
The Linux dialogue will be similar.
If you already have an OpenOffice.org application open, for example a Writer, Calc or Impress 
application:

• File » New.

This will take you directly to the Open File dialogue.

___________________________________________________________________________
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• Located the directory (folder) in which the database is located and highlight the database.
• Click OK.
• Click Tables in the left hand (Database) pane.

• Click a table in the Tables pane. In this case, we click the table called People.

In the above case, the table is extremely simple. It consists of only two fields called Country 
and Population.

As a matter of interest, all the figures that are used in this example and those that follow are 
real life figures extracted from the CIA Factbook. If you wish to have access to all the data 
with  a  view  to  constructing  more  extensive  databases  based  on  actual  data,  it  can  be 
downloaded free of charge from www.cia.gov/cia/publications/factbook/ 
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To close the database:

• File » Close

and to exit the application completely:

• File » Exit

5.1.2.3 Create a new database.

We will now go through the steps to create the simple database that was illustrated previously.

• Create a directory in which to save your databases. This could be D:\DATA\DATABASES 
(Windows) or /HOME/DATABASES/ (Linux). The actual paths would depend on how your 
system is set up.

• Proceed through the steps detailed  in  section  5.1.2.2 to open Base until  the following 
screen is displayed:

• Make sure the Create a new database radio button is checked.
• Click Next.

___________________________________________________________________________
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• Click Finish as there is nothing we need to change on this screen.
• You will now be prompted for a name of the database and a location win which to save it.

• Select a location and enter a file name.
• Press Save when done.
• Press Tables in the Database pane on the left.

___________________________________________________________________________
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As a database is made up of a number of tables, we need to start by constructing a simple 
table.

• Click Create Table in Design View in the tasks pane, the upper left pane.

The screen that appears allows you to create the fields of the database. Each field is given a 
name and a  type.  The field  types are  selected by  clicking  on the drop down arrow.  This 
displays the various options.

• Create a field called Country. Select Text (Fix) [CHAR] as its type.
• Create another field called Population. For it's type, select Integer.

Important: Do not use Text [VARCHAR] as the field type as this will create problems when 
we use the field in a relation.  (Variable Characters – may change).

___________________________________________________________________________
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• Click on the left hand side of the first field, 
Country, to select it.

• Right click to display a Contextual menu
• Select Primary key.

Recall each table should have a primary key 
that will be used to provide a unique identifier 
for each record.

Note that a small key will be displayed next to 
the field name. This indicates that it is the 
primary key for the table.

• File » Close.
• Enter People as the table name.
• Click OK.
• File » Close.

The reason we had to repeat the File » Close is because the table did not yet have a name. 

The creation of tables and data entry will be covered in  detail in the next chapter. The purpose 
of this section was to give you a feel of the way in which databases are constructed.

5.1.2.4 Save a database to a location on a drive

As mentioned in the section 5.1.2.3, when you 
create a database, you will be asked for a 
name and a location in which to save it. In the 
case of a Windows system, you will need to 
select a device such as a hard drive, floppy 
drive, CD or flash disk.

• Select a device.
This will displays a directory structure for 
the device.

• Double click on a location in the directory 
tree.

• Click Open.

In the case of Linux systems, you are 
immediately presented with a directory tree as 
all devices are located at branches in the tree.

___________________________________________________________________________
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5.1.2.5 Use available Help functions.

The help system of OpenOffice.org provides a complete reference to the system.

Contents

• Help » OpenOffice.org Help.
• Click on  the Contents tab.

This accesses the help system of OpenOffice.org, not just Base.

• Click on the Contents tab.

Each book represents a major section.

• Double click on any book icon, for example  Database Functionality. This will display the 
contents which may be further subsections or actual entries.

• Double click on a section, for example Tables, Queries and Indexes.
• Double  click  on  a  subsection,  for  example  Tables.  The  right  hand  pane  will  contain  a 

detailed description of the topic.

This example is illustrated in the previous screen.

___________________________________________________________________________
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Index

The Contents tab is the same as the table of contents at the front of the book. This organises 
entries by function.

The Index tab functions in the same way as the index at the back of the book. This provides 
an alphabetic listing of topics.

• Click on the Index tab.
• Begin typing a term that you are interested in  into the  Search term window. Type for 

example the word table.

OpenOffice.org  will  attempt  to  anticipate  what  you are  searching  for.  As  you type in  the 
Search term window, the alphabetic listing of topics will change. The entries are divided into 
headings and actual topics. The headings are flush against the left hand side of the pane while 
the actual topics are slightly indented.

• Double click on an entry. For example, click on Table design of data sources.

The right hand pane contains the details of the topic you have selected.

Within the details of the entry you will also see a number of hyperlinks. These are underlined 
in blue. These are references to related topics. To jump to one of these entries, double click the 
hyperlink.

Find

OpenOffice.org  provides  yet  another  method  of  searching  for  information.  Whereas  both 
Contents and Index are based on an alphabetic listing of topics,  Find allows you to search 
within the text of the entries for topics using a keyword.
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Suppose you did not find the previous description of the term field adequate and you wish to 
find all topics in OpenOffice.org that make reference to this term.

• Click on the Find tab.
• Type the work field into the Search term window.
• Click Find.
A list of entries that contain the word field are displayed.

• Double click on the entry that you wish to read.

The occurrences of the search word are highlighted in the details window.

Print entries in Help

• Click the print icon, .

Create bookmarks

When you read a book you may sometimes turn the corner of a page to mark important pages 
for easy later reference. A bookmark is the electronic equivalent.

• Click the create bookmark icon, , to mark an entry.
• Enter a name for your entry in the Add to bookmarks dialogue.
• Click OK.

___________________________________________________________________________
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Use bookmarks

• Click on the Bookmarks tab.

A list of bookmarks you have created will be displayed.

• Double click on an entry to read the details.

5.1.2.6 Close a database.

This was covered in section 5.1.2.2

5.1.3 Adjust Settings

5.1.3.1 Change between view modes in a table, form, report.

The Database pane on the left hand side of the screen provides access 
to various views on the data in the database.

Table provides a view on the basic data storage unit for records. The 
table view looks much the same as a spreadsheet. Each record is 
represented by a row of the table while the columns represent the 
fields.

Queries look much the same as tables. The records however, may be 
selected on the basis of one or more criteria. In addition, the fields 
maybe extracted from more than one table.

Forms represent formatted data from tables and queries.

Reports are summaries of data extracted from forms and queries. 
They may contain additional calculations and text added to make the 
output readable. Reports are generally designed to be printed out.

These views are illustrated below.

Table view Query view

___________________________________________________________________________
Page 5.18



5.1 OpenOffice.org Base: Using the Application
_______________________________________________________________________________________________

Form view

Report view

5.1.3.2 Display, hide built-in toolbars.

• View » Toolbars

The sub-menu that is displayed shows the 
available toolbars. Those that are displayed are 
ticked in the menu.

Each of the options is a toggle. Selecting a 
displayed toolbar causes it to be hidden, while 
selecting a hidden toolbar causes it to be 
displayed.

As the toolbars are quite small, they are displayed next to each other rather than below each 
other. The following screen shows all the toolbars displayed.

___________________________________________________________________________
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If only the standard toolbar was displayed, the toolbar would appear as follows:

If you wish, you can create a customised 
toolbar.

• Toolbars » Customize.

This displays the Customize dialogue.

You may modify an existing toolbar or add 
commmands to it.

• Click Add.
• Select a Category containing the command 

you wish to add.
• Select the Command.
• Click Add.
• Repeat for other commands.
• Click Close when done.
• This process may be repeated for other 

categories.

___________________________________________________________________________
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5.2 Tables

5.2.1 Main Operations

5.2.1.1 Create and save a table and specify fields with their data types.

• Open Base as previously described.
• If you have already created the  Africa database, open it.  Otherwise, creat a database 

called Africa and save it in an appropriate directory.
• Click Tables in the Database pane.
• Click Create Table in Design View in the Tasks pane.
• In the Field Name column, type Country.
• In the Field Type column, leave the default field type as Text (FIX) [char].
• Right click at the start of the row and select Primary key from the context menu.
• In the Field Properties area, chang the Length from 50 to 35.

The reason for this change is that Base sets aside a certain amount of memory for each field. 
This is known as the field length. If it is longer than is required, memory is wasted. If it is too 
short, then not all  the data will  be able to be entered. Make sure the field length is long 
enough to handle the largest field, but not unnecessarily long.

• Go to the second row and enter Population as the field name.
• Click on the drop down arrow in the Field Type column.

The  drop  down  window  will  indicate  a  large  number  of  different  data  types.  This  is  to 
accommodate the range of data that have been adopted in the various SQL standards over the 
years. To understand these fully would require going into very technical issues. The following 
description simplifies the types to the needs of these notes. 
Until you study Base at an advanced level, you will be fine using only the following field types.

Numeric: Both refer to numbers that can be positive or negative (ie are signed) and can 
have a fractional (decimal) part. Technically, float contains a number that is 
only approximate while decimal is exact. Only use numeric fields if there is 
the possibility that you will perform arithmetic on their contents.
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Integer: If a numeric field will only contain whole numbers (integers), then it is more 
efficient to use an integer type field. Numbers with fractions or decimal parts 
cannot be stored in an integer field.

Text: Use this for fields that contain small amounts of text. Technically, the limit is 
255 characters. Use text for fields containing numbers if you do not intend to 
do arithmetic on the numbers.

We will always use the form Text (Fix) [CHAR].

Memo: Use memo fields if you wish to store large amounts of text. Technically, you 
must use a memo field if a field is to contain more than 255 characters. Base 
works differently with memo fields and text fields. In the case of text fields, 
Base sets aside a fixed amount of space but in the case of memo fields, the 
data is kept in a storage area outside of the table.

Date: Use  date  to  store  date  fields.  A  certain  amount  of  arithmetic  may  be 
performed on date fields. For example, you can add or subtract a number 
(days) to a date to get another date. If you subtract one date from another, 
you get the number of days between. Date fields store day, month and year.

Time: This type of field can store time in the form of hours, minutes and seconds.

Boolean: Boolean can store a value which has only two possibilities such as 1/0, True/ 
False, Yes/No

• Create a second field called Population with field type Integer.
• Notice the Field Properties.

• If you wish to force a value to be inserted when the record is created, change the Entry 
required property from No to Yes.

• You can also automatically insert a value when the record is created by entering the default 
value for the field in the Default value property. We will not do so in this case as it would 
not serve any useful purpose.

• File » Close.
• Call the table People and click OK. 
• File » Close.
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5.2.1.2 Add, delete records in a table.

• Click on Tables in the Database pane.
• Double click on People  in the Tasks pane. This will open the 

table for data entry.
• Click on the left hand cell and type in the country name 

Algeria.
• Press Enter or Tab. The cursor will jump to the right hand 

cell.
• Enter the value 32531853.
• Press Enter or Tab. This will create a new record.
• Continue in this way until all the data shown on the adjacent 

screen has been entered.

• Click the Close icon, 
• To delete an entire record in a table, select the grey bar to 

the left of the record and press Delete, you will be prompted 
to ask if you are sure, choose Yes.

Note that File » Close will not only close the table but will also 
close Base.

5.2.1.3 Add a field to an existing table.

• Open the Africa database if it is not already open, and 
click on Tables in the Database pane.

• Click Edit in the contextual menu.

The  Table will  be displayed in a form allowing it  to be 
edited.

• Add  three  more  fields  as  shown  in  the  following 
screen.

• Click the Close icon, 
• Answer Yes when asked if you wish to save the changes.
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5.2.1.4 Add, modify data in a record.

• Double click on the table People.

This will displayed the contents ready for 
editing. Notice that the Birth Rate and Notes 
columns are empty. 

The previous section illustrated the process of 
adding records. If you wish to change data in 
any record, click on the cell containing the data 
and edit in the same way you would edit any 
text.

• Enter the data into the blank cells as shown 
on the adjacent screen.

• Click on the left hand cell of the blank row 
at the bottom. Enter the additional data as 
shown on the adjacent screen.

5.2.1.5 Delete data in a record.

Delete data

• Highlight the data or text you wish to delete.
• Press Del.

Delete a Record

• Select the grey bar to the left of each record you wish to delete.
• Press the Del key.
• Confirm that you wish to delete the selected records.
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5.2.1.6 Use the undo command.

• If you make a mistake, Edit » Undo  or press Ctrl+Z immediately after you have made a 
mistake. This will restore the database to the state immediately preceding the operation. 
Effectively, Ctrl+Z cancels the last operation.

Be careful, Undo does not always work. For example, once you have confirmed that you wish 
to delete one or more records, Undo will not be able to recover them.

5.2.1.7 Navigate within a table to next record, previous record, first record, 
last record, specific record.

The Navigation bar is located at the bottom of the table.

This indicates the number of the current record as well as the number of records in the table. 

If you know the number of the record you wish to go to, type in the number and press Enter.

When  you  move  to  a  record  in  the  table,  the  first  field  in  that  record  will  be  selected 
(highlighted).

To the right of the number of records are four motion icons. Clicking these will move you to the 
first, previous, next and last record respectively.

Clicking on the last item will create a new record. The cursor will be positioned in the first field 
of the new record. You may then enter the data for the record.

5.2.1.8 Delete a table.

• Display the list of available tables by clicking on Tables in the Database pane.
• Right click on the table you wish to delete and select  Delete  in the contextual menu or 

press Del.
• A dialogue will display the name of the table you wish to delete and ask you to confirm.

• If you are sure you want to delete the table, click Yes. Otherwise, click No to cancel.

Note that Undo will not allow you to recover a record once you have answered yes.
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5.2.1.9 Save and close a table.

• Click the Close icon on the top left of the table 
screen.

• Click Yes to save changes and close
Click No to abandon changes and close
Click Cancel to return to the table.

5.2.2 Define Keys

5.2.2.1 Define a primary key.

Recall that the primary key is the unique field which is used to identify each record in a table. 
It can also be used to link one table to another in a relationship.

Careful thought needs to be giving as to which field will be the primary key for a table. For 
example, at first glance a Name might seem to be a good primary key. This, however, cannot 
work since may people have the same name and even the same combination of names. If 
possible, rather use an existing real identifier such as a national identity number. This is a 
better option than creating an artificial field.

Sometimes it is necessary to create an identifier such as a customer number. This would be 
necessary when a company has clients that can be both individuals and other companies.

• Right click on the Table whose Primary key you wish to set or change and select Edit.
• Right click on the field that you wish to set as the primary key.
• Click on Primary key in the contextual menu.

If a primary key has been set previously, it will be changed to the new field since a table may 
only have one primary key.

5.2.2.2 Index a field with, without duplicates allowed.

Indexing is a technique that allows records to be sorted rapidly based on fields which have 
been indexed. In some database systems such as Microsoft Access, fields can be explicitly 
indexed. A table can be sorted more rapidly on a field that has been indexed than on one 
which has not. In addition, it is possible to specify that an indexed field must be unique, ie 
without duplicates. In this way, an indexed field behaves similarly to a primary key.

• Open the People table for editing.
• Tools » Index design.

• Click on the New Index icon, .
• Select Population in the Index field.
• Check the Unique tick box.

If this box is ticked, Base will not allow duplicates in this field - every value will have to be 
unique.

• In the Sort order column, select ascending.
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• Create additional index fields, if required.
• Click Close when finished.

Since the requirement of no duplicates makes no sense in this case, we remove the restriction 
as follows:

• Tools » Index design.
• Click on index1.
• Uncheck the Unique tick box.
• Close and save changes.

5.2.3 Table Design/Layout

5.2.3.1 Change field format attributes such as: field size, number format, 
date format.

Field Size

In an earlier section we described the significance of field size. It is sometimes difficult  to 
estimate this in advance. You can change this at a later stage if you wish.

• Open the People table for editing.
• Select the Country field.
• In the Field Properties pane, change the field size from 35 to 30.
• Close and accept the changes. 
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Be careful when you reduce field size. If you shorten a text field, you could lose data. You will 
not be able to recover this even if you lengthen the field at a later stage.

Number Format

You can change number formatting in two ways. You could change the field type, for example, 
from Numeric to Integer or you could change the formatting.

Be  careful  of  changing  to  Integer from  Numeric.  If  your  data  contained  any  fractional 
components,  these would  be lost.  Changing  back  to  Numeric would  not  recover  the  lost 
fractions.

• Open the People table for editing.
• Select the  Birth Rate field.
• Change the filed type from Real to Double.

Double is able to store numbers to a higher degree of accuracy, but takes considerably 
more memory and is slower to perform arithmetic on.

• Close and accept changes.
• Open the table for data entry.

The change has had no visible effect on the field as it is an internal process.
• Open the table for editing once again.
• Change the Birth Rate field back to Real.
• Click Format example.
• Change the number of decimal places to 3 as shown on the next screen.

• Click OK.
• Close and accept changes.
• Open the table for data entry.

Notice that all  the birth rates are expressed to three decimal  places. Trailing zeros are 
added where necessary.

Look  at  the  previous  screen.  This  illustrates  the  range  of  formats  that  numbers  can  be 
expressed in. In particular, Currency is a very useful format. We can enter currencies as pure 
numbers and have them formatted correctly in an appropriate currency.

___________________________________________________________________________
Page 5.29



5.2 OpenOffice.org Base: Tables
_______________________________________________________________________________________________

Date Formats

• Open the People table for editing.
• Create a new field called Last Update and make this of Date type.
• Now click on Format example in the Field Properties window.

• Select a date Format and click OK.
• Close and accept the changes.
• Now open the table for data entry.
• Enter a date in one of the Last Update fields. Use any date entry format you prefer.
• Click on another field.

Notice how the date changes format to the one you specified.
• Close.
• Right click on the table and select Edit.
• Select the Last Update field.
• Click Format example and select a new date format.
• Close and accept changes.
• Open the table for data entry.

Note the format of the date you entered has now changed.

5.2.3.2 Understand  consequences  of  changing  field  size  attributes  in  a 
table.

Reducing field size saves memory. For example, the shorter text is, the less memory it uses. 
Similarly, for number fields, Integer uses less memory than Real and Real in turn uses less 
memory than  Double. In general, using a shorter field length also leads to faster database 
operation.

On the negative side, you could lose data if the text length is too small or you could lose the 
accuracy of your numeric data. For example, converting from Real  to  Integer will  result in 
loss of all fractional data. This cannot be recovered by converting back to the original length or 
type.

___________________________________________________________________________
Page 5.30



5.2 OpenOffice.org Base: Tables
_______________________________________________________________________________________________

For example, suppose a text field is initially 25 characters long and that one record has an 
entry  in  this  field  “Annabella  van  Kettering”.  This  name contains  23  characters,  including 
spaces.  Suppose  now you  reduce  the  length  of  the  field  to  20  characters,  the  last  three 
characters will be discarded and the field will  contain “Annabella van Ketter”. Once the field 
has been truncated (the last few characters discarded), there is now way of restoring them.

5.2.3.3 Create  a  simple  validation  rule  for  number,  text,  date/time, 
currency.

A validation rule is a feature that checks whether data entered into a field meet certain criteria. 
If the data does not meet these criteria, it is rejected. A simple criteria might be that a number 
must be positive and between 0 and 100.

At present, in the Base program, the only rule that can be applied, is that the field may not be 
empty.

5.2.3.4 Change width of columns in a table.

If the width of a displayed column is too narrow or too wide it can be adjusted using click and 
drag.

• Open the People table for data entry.
• Position the cursor over the dividing line between the headings Country and Population.

• When the  marker  is displayed, hold down the Ctrl key, and use the mouse to drag 

the boundary to the left or right to narrow or expand the Country column.
• To change the width to a specific size, select the column that you wish to change,  right 

click on them and choose Column Width – specify the width you require.
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5.2.3.5 Move a column within a table.

Base does not allow you to change the order of the columns or fields in a table. To see the 
columns displayed in a different order, you would need to create a query based on the table. 
This can then have the columns in any order. This topic will  be covered in the sections on 
queries.

5.2.4 Table Relationships

5.2.4.1 Create a one-to-one, one-to-many relationship between tables.

A relationship is a method of connecting the data in two or more different tables. Only one 
table can be active at a time. We can refer to this as a primary table. The tables to which the 
primary table is linked are secondary tables.

A relationship has a direction, namely from the primary to the secondary table.

The tables are linked via a common field. A common field is one which contains matching data 
in the two linked tables. The simplest and clearest method of linking two tables would be via a 
primary key which is the same in both.

We will illustrate this by means of an example.

• Open the Africa database and create a new table called Economics. This has two fields:
Country, a text field of length 35, primary key
Per capita GDP, this is structured as shown on the screen  below.

• To achieve this:
Set Field Type to Numeric
Click Format Example.
Select Currency in Category.
Select the appropriate Format.
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Click OK.
• Close and save changes.
• Give the table the name Economics.

A Trick

At this point, you would have to type in all the names of the countries. Here is a trick to avoid 
this.

• Delete the Economics table you have just created by highlighting it and pressing Del.
• Highlight the People table.
• Edit » Copy
• Edit » Paste
• When prompted, call the copy Economics.
• Right click on Economics  and select Edit.
• Delete all the fields except country by clicking on the grey block at the start of the rown 

and pressing Del.
• Create a new field Per Capita GDP  as described earlier.
• Close and save changes.
• Open Economics for data entry.

You will see all the countries listed. You only need to enter the empty field.
• Enter the Per Capita GDP as shown on the following screen.

• Only type the numbers in without any 
formatting.
Notice that as you click on another block, 
the number will be formatted to currency.

• Right click on the Per Capita GDP title.

• Click Column Format.
• Click the Alignment tab.

• Select Right in the drop down window and 
click OK.

• Click close when complete.
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What we now have is two tables with identical  Primary keys. These will form the link in the 
relationship between the two tables. Once the relationship is created if, for example, we have 
People open  with  Nigeria the  current  record,  then  in  the  background  a  pointer  will  be 
indicating the Nigeria record in the Economics table. This will give us access to this data as 
well.

The next step is to create a relationship between the two tables. We will use the term Parent 
and  Child tables rather than  Primary and  Secondary. In this case we would like to make 
People the Parent and Economics the Child. 

Notice that each table has a single record for each country. Because of this we say that we are 
setting up a One-to-one relationship between the tables.

We do not need to use the Primary key for linking two tables. Other fields could be used. It is 
possible that these will contain duplicates, ie that the same value may occur more than once in 
the field. This will mean that at times there may be more than one link from a record in the 
Parent to records in the Child. In this case, we say that the relationship is One-to-many.

Other possibilities are duplicated fields in both the Parent and Child or duplicated fields in the 
Parent but not in the Child. In these cases the relationship is said to be Many-to-many or 
Many-to-one respectively. We will only be concerned with One-to-one and one-to-many.

• Tools » Relationships.
• Insert » Add Tables.
• Add the People and Economics tables.
• Click and hold down the left mouse button on Country in the Economics table.
• Drag over to Country in the People table.  

This  will  draw  a  line  between  the  linked  fields  in  the  two  tables.  This  indicates  the 
relationship.

• Right click on the relationship and select Edit.

In the Relations dialogue, the Parent will be shown on the left and the Child on the right. If 
you had clicked and dragged in the opposite direction, the columns would be reversed.

• Click Cancel.
• Close and save changes.
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To illustrate a One-to-Many relationship we will need to create another table.

• Create a table called Presidents with three fields:
Country: text, size 35, but NOT  as a Primary key.
President: text size 40
Notes: memo
RecordId, Integer, Primary key.
In the Field Properties window, set AutoValue to Yes.

• Close and save changes.
• When prompted for a Primary key, allow Base to create one for you.

In the Presidents table, there could be several entries for each country. This means that if we 
create  a  relationship  between  People  (the Parent)  and  Presidents  (the Child),  the 
relationship will  be  One-to-Many.  Conversely,  if  we had created the relationship  between 
Presidents and People, it would have been Many-to-One.

• Tools » Relationships.
• Insert » Add Tables.
• Add the Presidents table.
• Drag the tables so that they are spaced in such a way as to see the relationships clearly.
• Click on Country in Presidents.
• Click and drag onto Country in People.

Note the 1 next to People and the n next to Presidents. This indicates One-to-Many.

• Close and save changes.
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• Open  Presidents  for data entry and enter 
the adjacent data.
Note that we are deliberately not creating a 
record for each country.

• Close and save changes.

• Close this table. We will use it again in the final section of this chapter.

5.2.4.2 Delete relationships between tables.

• Tools » Relationships.
• Right click on the relationship you wish to delete.

• Click Delete.
• Close and save changes.

5.2.4.3 Apply rule(s) to relationships such that fields that join tables are 
not deleted as long as links to another table exist.

Before we go any further we will need to clarify some terms.

A query can be viewed as a table that is constructed from some or all of the data contained in 
other tables. It may comprise only some of the fields and its records may satisfy additional 
constraints.

When we create a relationship between two tables, the link is also called a join. A join can 
be of different types.
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Inner Join:  With the internal join, the results table contains only the records for which the 
content of the linked fields is the same.
Left Join: With the left join, the results table contains all fields of the left table and only those 
fields of the right table for which the content of the linked fields is the same.
Right Join: With the right join, the results table contains all fields of the right table and only 
those fields of the left table for which the content of the linked fields is the same.
Full Join: For a full join, the results table contains all fields of the left and right tables.  This 
option is available in SQL and will not be covered in this course.

We will need to use queries to study relationships in more detail.

• Click on Queries in the Database pane.
• Click Create Query in Design View in the Tasks pane.
• Double click People in the Add Tables dialogue.
• Add Presidents in the same way.
• Drag the Presidents table so that the two tables are a distance apart.
• Double click the join between the tables.
• Click on the Type drop down window.

Your screen should appear as below.

• Select Left Join and click OK.
• Click on the Table cell of the first column and select People.
• Click on the Field cell of the first column and select Country.

The shorthand for this is People.Country.
• Click on the Table cell of the second column and select Presidents.
• Click on the Field cell of the second column and select President.

The shorthand for this is Presidents.President.

Note: Base automatically prevents you from deleting a field that is part of a relationship. If 
you do attempt to do so, an error message will be displayed.
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• Close and save changes.
• Give the query the name Presidents.
• Open Presidents for editing.

As  was  mentioned  earlier,  referential  integrity  refers  to  maintain  a  database  free  of 
inconsistent data.  Base automatically looks for violations of referential integrity and will not 
allow you to insert inconsistent data.

In order to assist in maintaining integrity, Base can impose additional constraints on relations.

• Go to the Tables view of the Africa database.
• Tools » Relationships.
• Click on the join between People and Presidents.
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The  Relations dialogue allows you to set options that  occur when records are updated or 
deleted. These are set by checking the corresponding radio button. The following is a summary 
of the actions taken directly from the OpenOffice.org Help system.

Update options

Here you can select options that take effect when there are changes to a primary key field.

No action: Specifies that any change made to a primary key does not affect other external key 
fields.
Updating cascade:  Updates  all  the  external  key  fields  if  the  value  of  the  corresponding 
primary key has been modified (Cascading Update).
Set null:  If the corresponding primary key has been modified, use this option to set the "IS 
NULL" value to all external key fields. IS NULL means that the field is empty.
Set default: If the corresponding primary key has been modified, use this option to set a 
default  value to all  external key fields. During the creation of the corresponding table, the 
default value of an external key field will be defined when you assign the field properties.

Delete options

Here you can select options that take effect when a primary key field is deleted.

No action: Specifies that the deletion of a primary key will  not have any effect on other 
external key fields.
Delete  cascade: Specifies  that  all  external  key  fields  will  be  deleted  if  you  delete  the 
corresponding primary key field.
When you delete a primary key field with the Delete cascade option, all records from other 
tables that have this key as their foreign key are also deleted. Use this option with great care; 
it is possible that a major portion of the database can be deleted.
Set null: If you delete the corresponding primary key, the "IS NULL" value will be assigned to 
all external key fields.
Set Default: If you delete the corresponding primary key, a set value will be set to all external 
key fields.
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5.3 Forms

5.3.1 Working with Forms

5.3.1.1 Open a form.

A form can be opened by  clicking on its icon in forms view. The following example assumes 
that there is a form called People in the Africa database.

• Open the Africa database.
• Click on Forms in the Database pane.

• Double click on People in the Forms pane.

Notice the scroll bar at the bottom of the screen. This functions in exactly the same way as 
the scroll bar when records are displayed.
• Click the Close icon when down.
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5.3.1.2 Create and save a form.

• Make sure you are in Forms view.
• Click Use a Wizard to Create a Form.

This will display the Form Wizard.  
• In the Tables of Queries drop down window, select Table: People.
• Double click on the fields: Country, Birth Rate, Population and Notes.

These are the fields that you would like to appear on the form.

• Click Next.
• Click Next  on the next dialogue.
• Click Columnar Labels Left.

This is the first option of the Arrangements.
As you select and arrangement, the form will change accordingly. 
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• Click Next.
Notice the options available for data entry mode.

• Click Next as the above settings are what we need.
• If you wish you can change the style of the form.
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• Apply a different style, if you wish.
• Click Next.
• Give the form the name People Data.  This last option would be to name the form and 

automatically save the form as such.

• Click Finish.
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The form can now be used for viewing, adding, deleting or editing data.

5.3.1.3 Use a form to enter, modify, delete records.

Enter a new record

• Click the New Record icon on the scroll bar.

This displays a blank record on the screen.

• Enter the data shown on the following screen.
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• Close and save changes or add another record to save the record you have just added.

Delete a record

• Click on the Delete icon on the Scroll bar.

• Click Yes to confirm that you wish to delete 
the record.

Note that once a record is deleted, it cannot be 
recovered.

Edit a record

• Locate the record you wish to edit.
• Make the changes on the form.
• Either close or go to another record. When you do, the changes will be recorded.

5.3.1.4 Go to next record, previous record, first record, last record, 
specific record using form display.

The Scroll bar at the bottom of the screen provides a number of methods for locating records.

• Enter a record number into the Record window and press Enter.

The next four icons allow you to scroll through the records. They are respectively:
- Goto first record
- Go to previous record
- Go to next record
- Go to last record.

• Click on the first icon (the binoculars).
• This will display a Search dialogue which will enable you to locate a record in terms of its 

contents.
• For example, to find information on Algeria you would change the dialogue as shown on 

the following screen.
Notice the range of options that can be set when searching. If you tick Match case, then 
the search will not only match the letters but also whether they are upper case. Algeria 
would be treated as a different word to algeria.
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5.3.1.5 Add, modify text in Headers, Footers in a form.

A header or footer is any data or information that appears identically at the top or bottom of 
each form.

The items that appear on a form are called controls. One example is a field and field label 
taken from a table. Controls that contain fixed text are called labels. Headers and footers only 
appear at the top or bottom of a form. Headings can be inserted anywhere. Labels are used to 
insert headings.

Headings

In this example, we will put a label on each form. This will indicate the title of the form.

• Open the People form for editing.

We need to make space for the heading so we will need to move all the fields and labels.

___________________________________________________________________________
Page 5.47



5.3 OpenOffice.org Base: Forms
_______________________________________________________________________________________________

• Hold down the Shift key and click on each 
of the fields.

• Move the cursor over the selected fields. 
When it appears as a cross-hair, drag the 
controls down the form.

• Click  on  the  Label  control  in  the  Form 
toolbox.

• Drag and mark out an area for the label. This will appear as a rectangular area.
• Right click on the label and select Control. This will display the label properties dialogue.
• Type African Population Details into the Label property.
• Set a font by clicking on the Font property. For example, set the font to Verdana, 12pt 

bold.
• Notice the other properties that you can set.

• Close the Properties dialogue when done.
• Close and save changes.
• Open the form in data entry view and scroll through the records. Notice the effect of our 

heading.

Headers and footers

• Open the form for editing.
• Insert » Header.
• If Default is checked, press Esc, otherwise 

click Default.
• Do the same with Insert » Footer.
• View » Print Layout.

If Print Layout is already checked, press 
Esc.
The header and footer areas will be marked 
out by horizontal lines.
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• Scroll down to the bottom of the form.
• Position the cursor in the footer.
• Press the Centre Justify icon.
• Insert » Fields » Date

Notice the other fields that you could have inserted.
• Right click on the Date, select Fields.
• Select a suitable format for the date and click OK.
• Close and save changes.
• Open the form in data entry view and scroll through the records to see the effect.

Edit Header / Footer

You can delete, enter or modify text and fields in the Header / Footer by scrolling down to the 
footer and treating the entries in the same way as any other text, the same applies with the 
Header.

5.3.1.6 Delete a form.

• Right click on the form in the Forms pane.
• Click Delete.
• Confirm that you wish to delete the form.

5.3.1.7 Save and close a form.

• Click the Close icon in the top right had corner.
• Click  Accept  or  Discard  depending on what you wish to do with the changes you have 

made.
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5.4 Retrieving Information

5.4.1 Main Operations

5.4.1.1 Use  the  search  command for  a  specific  word,  number,  date  in  a 
field.

• Open the People table.
• Click the Find icon on the toolbar.

This displays the Record Search dialogue.

The options are as follows:

Search for: Text
Field content is NULL: This refers to empty fields
Field  content  is  not  NULL:  This  refers  to  fields  which  contain 
something, where the actual contents are not relevant.

Where to search: All fields: The search will scan all fields.
Single field: The search will only scan a single field in each record. This 
Field is selected from the adjacent drop down window.

Position: This option is selected from the drop down window. Options are:
Anywhere in the field
Beginning of the field
End of the field
Entire  field:  In  this  case  the  contents  of  the  field  must  match  the 
search text exactly.

Settings: These specify additional aspects of the search.
Apply field formats:  The formatting  must match in  addition  to the 
text.
Match case: The search must match both the text and their case. 
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For example, Zambia will not be a match for zambia.
Search backwards: Normally a search is conducted from the current 
record forwards. If this option is selected, the search will be conducted 
in the opposite direction.
From top: The search will be conducted from the start of the database 
irrespective of the current record.
Wildcard expression: This enables you to use place holders to replace 
one or more letters. You would use this when you are not sure of the 
spelling.

You can use the following wildcards:

? for  exactly  one 
arbitrary character

"?loppy" returns "Floppy"

"M?ller" returns, for example, Miller and Moller

* for  0  or  more 
arbitrary characters

"*-*" returns "ZIP-Drive" and "CD-ROM"

"M*er" returns all  entries starting with an "M" 
and ending in "er" (for example, Miller, Moller, 
Mather)

If you want to search for the actual characters ? or *, preface them with 
a  backslash:  "\?"  or  "\*".  However,  this  is  only  necessary  when 
Wildcard expression is enabled. When the option is not enabled, the 
wildcard characters are processed like normal characters.

The other options do not concern us at this stage.

• Complete the Record Search dialogue as shown on the following screen.
• Click Search.

This locates the first record satisfying the search.

• Click Search repeatedly.
Notice how the search will locate the records one at a time. When it has reached the last 
record, the search will return to the first. You may edit the records as they are located.

___________________________________________________________________________
Page 5.52



5.4 OpenOffice.org Base: Retrieving Information
_______________________________________________________________________________________________

Note: Searching for numbers and dates: If you wish to search for a number or a date you 
use the same dialogue. In place of the text, enter the number or the date you wish to search 
for. Remember to select the appropriate field.

Searching forms

Searching forms operates in a similar way to 
searching tables. The search dialogue for 
forms is displayed on the adjacent screen.

The major difference is that you can now use 
the search for changing text. This is the same 
as the Find & Replace in Writer.

You have the option of scrolling through the 
records and individually replacing or not. 
Alternatively, you can do a global replacement 
which will make the changes to all the records 
at once.

5.4.1.2 Apply a filter to a table, form.

A filter selects all records which satisfy certain conditions.

• Open the People table.
The toolbar contains four icons relating to filters. These are 
Autofiler, Apply Filter, Standard Filter and Cancel Filter.

• Click the Standard Filter icon.
• Fill in the dialogue as shown on the following screen and click OK.

• Click the Standard Filter once more.
• Complete the dialogue as shown below and press OK.
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In this case, records satisfying either the first or the second condition will  be displayed. We 
could set a third alternative if we wished. It is important to note that in the case of OR, records 
only need satisfy one of the conditions in order to be displayed. If we were to use AND, all the 
conditions would need to be satsified.

• Click the Standard Filter icon once more.
• Edit the dialogue as shown on the following screen and press OK.

The first  condition  means  that  the  Country must  begin  with  a  letter  preceding  L in  the 
alphabet.  The  second  condition  means  that  the  Population must  be  greater  than 
10,000,000. Because AND is used, both conditions must be satisfied by each record.

Conditions can be: = : Equal to numerically or identical to if text.
<> : Not equal to
> : Greater than or after
>= : Greater than or equal to
< : Less than or before
<= : Less than or equal to
Like : Matches a string which may include wildcards
Not Like: Does not match a string which may include wildcards
NULL: Contains nothing
Not NULL: Contains something

Base will remember the last filter that was applied. The Apply Filter acts as a toggle. If the 
filter is applied, clicking it  will  remove the effects of the filter without actually clearing the 
filter. Clicking it a second time will reapply the filter.

The Autofilter has a special function. It filters records based on the current record.

• Place  the  cursor  in  a  field  name whose  content  you  want  to  filter  and  then  click  the 
AutoFilter icon. 
Only those records with content identical to the selected field name are visible.

Filters on forms

The action of filters on forms is similar to that on tables.

• Open the People form for data entry.
• Click the Form-Based Filters icon on the toolbar.

The current document is displayed with its form controls as an empty edit mask. The  Form 
Filter toolbar appears.
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• Enter the filter conditions into one or several fields. 
Note that if you enter filter conditions into several fields, all of the entered conditions must 
match (Boolean AND).
You may use wildcards in the conditions.

• Click the Apply Form-Based Filter icon on the Form Filter toolbar.
The filter will be applied. 

• Browse through the found records using the Form Navigation toolbar.
• Click the Apply Filter icon on the Form Navigation toolbar to change the filtered 

view.

5.4.1.3 Remove a filter from a table, form.

• Click the Remove Filter icon.
This not only removes the application of the filter from the table or form, but actually 
removes the definition of the filter itself.

5.4.2 Queries

5.4.2.1 Create and save a single table query, two-table query using specific 
search criteria.

A query provides a method of extracting records that satisfy certain criteria either from a single 
table or a group of related tables.

In this section we will construct two queries without conditions, one based on a single table 
and the other based on two related tables. In the next section we will add conditions to these.

Single table queries

• Go to Query view by clicking on Queries in the Database pane.
• If you have already created the query  Populous Countries, delete it by selecting it and 

pressing the Del key. Confirm that you wish to delete it.
• Click Create Query in Design view in the Tasks pane.
• When the Add Tables dialogue appears, select People and click Add. Then click Close.
•  In the Field cell of the first column, select People.Country.
• In  the  second  and  third  columns,  select  People.Birth  Rate and  People.Population 

respectively.
Notice that in creating the query, we do not need to use all the fields and we can place 
them in a different order to the table.
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• Close and save changes.
• Give the query the name Population.
• Double click on Population.

• Close the query.
• Click on Create Query in Design View.
• Add both the People  and Presidents tables.
• Close the Add Tables dialogue.
• Click on Country in the People table, hold down the left mouse button and drag onto 

Country in the Presidents table.
• Double click on the join and select Left Join in the Type drop down window.
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• Click OK.
• Select Presidents.Country, Presidents.President and Country.Population for the first 

three fields of the query.
• Close and save changes.
• Give the name Presidents and Populations to the query.
• Double click on Presidents and Populations.

5.4.2.2 Add criteria to a query using any of the following operators: < 
(Less than), <= (Less than or equals), > (Greater than), >= 
(Greater than or equals), = (Equals), <> (Not equal to), And, Or.

A query provides one of the essential mechanisms for extracting information from data. Not 
only does it  allow us to specify which fields we wish to see, but also to select only those 
records that satisfy certain conditions.

• Open the Population query for editing.
• Edit the query as shown on the screen below.

This will list the countries which have birth rates below 20 per 1000.
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• Edit » Run Query  OR click the Run Query icon .

As the next screen shows, Run Query allows us to see both the query and its effects. We can 
alter the query and execute the command as often as we need.

• Modify the conditions as shown below and execute Run Query.

___________________________________________________________________________
Page 5.58



5.4 OpenOffice.org Base: Retrieving Information
_______________________________________________________________________________________________

Explanation: This is an important example. We wanted to display countries that have a birth 
rate greater than 20 but less than 30. To do so we need two conditions,  >20 AND <30. 
Because of the  AND, they must both appear on the same row. To do this, we add another 
People.Birth Rate column but uncheck the  Visible option. We can then set an additional 
constraint on the field.

There is an AND between all conditions on the same row and an OR between conditions on 
different rows. Be sure you understand the difference between these very clearly. A good way 
of doing so is to experiment with a query such as the one above. Try out different situations so 
that you can see the effects.

There are a number of operators that can be used in queries.

For example:
Operators can be: = : Equal to numerically or identical to if text.

<> : Not equal to
> : Greater than or after
>= : Greater than or equal to
< : Less than or before
<= : Less than or equal to
And : Will return information that lies between the two values x and y.
Or : Will return information that lies between the two values x or y.

Criteria listed for Country field
=South Africa  (will show only entries for South Africa
<> South Africa (will show all entries excluding South Africa
South Africa OR Namibia (will return all South African and Namibian entries)

Criteria listed for Birth Rate field
>25 (will list all entries that have a birth rate above 25)
>=25 (will list all entries that have a birth rate 25 and above)
<25 (will list all entries that have a birth rate below 25)
<=(will list all entries that have a birth rate 25 and below)
>=25 AND <=30 (will return all entries 25 to 30)
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5.4.2.3 Edit a query by adding, removing criteria.

If you press the Clear Query icon, not only the conditions but also the fields themselves 
will be cleared in the query window.
You would only use this if you wish to start completely from scratch again with a query.

If you wish to delete a field from a query, click on the field heading and press Del.

Usually we simply edit the Conditions and then execute Run Query.

To illustrate some of the ideas above, run the following two queries. 
Important: Enclose the J within quotes, thus 'J'.
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5.4.2.4 Edit a query: add, remove, move, hide, unhide fields.

• To add a new field, click on the Field cell at the top of a blank column.
• Select a field from the drop down window.

• To delete an existing field, click the grey cell at the top of the column.

• Press Del.

• To move a field, click and hold down the left mouse key on the grey cell at the top of the 
column.

• Drag the column to the new position.

You will  notice that an arrow is displayed indicating the position to which the field will  be 
moved.

To hide/unhide a field.  Often we wish to have a field in the query but do not wish to display 
it. Fields can be hidden or unhidden using the Visibility check box. If you do not wish a field to 
be displayed when the query is run, uncheck this box.
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5.4.2.5 Run a query.

This was discussed in section 5.4.2.4.

5.4.2.6 Delete a query.

• Click Queries in the Database pane.
• Select the query.
• Press Del.
•

5.4.2.7 Save and close a query.

This was discussed in section 5.4.2.1.

5.4.3 Sort Records

5.4.3.1 Sort data in a table, form, query output, in ascending, descending 
numeric, alphabetic order.

Sorting Tables

• Click in the column on which you wish to sort.
• Click on the Sort Ascending or Sort Descending icons. 

If the field is numeric,  sort ascending will  sort the table from the smallest to the largest 
value. If the field is text, then it will sort alphabetically starting with A. Sort descending will 
sort numeric data placing the largest first and will sort text data reverse alphabetically.

If the field on which you are sorting contains duplicates, you might want to sort on more than 
one field. For example, the first sort key might be Surname. If surnames are duplicated, you 
could sort records with the same surname on their First Name as the second sort key. 

• For compound searches, click the Sort icon.
This icon does not have a direction arrow on the side.

• Select fields for the first, second and third 
sort keys.

• Choose whether each of these keys should 
be ascending or desceding.

• Click OK.

___________________________________________________________________________
Page 5.62



5.4 OpenOffice.org Base: Retrieving Information
_______________________________________________________________________________________________

Sorting Queries

Queries can be sorted in exactly the same way.

In addition, sorting can be built into the definition of the query itself as shown on the following 
screen by selecting Ascending or Descending for the Sort option for a field.

Sorting forms

• Open the form for data entry and viewing.
• Click on the field on which you wish to sort the form.
• Click the Sort Ascending or Sort descending icons on the toolbar as shown in the next 

screen.
Base will then sort the records according to this field and the sort order selected.
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5.5 Reports

5.5.1 Working with Reports

5.5.1.1 Create and save a report based on a table, query.

A report is a highly formatted output document summarising information derived from tables 
or queries. It is generally designed to be printed.

• Open the Africa database.
• Click on Reports in the Database pane.
• Click Use Wizard to Create Report.
• In the Tables drop down window, select People.
• Double click the fields, Country, Population and Birth Rate.

Note: At this point you could create a report based on either a table or a query. The process 
is exactly the same.

• Click  Next  three times to skip the next few screens until  you get to the  Sort options 
dialogue.

• In Sort by, select Country and check the Ascending radio button.
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• Click Next.
• Choose a Layout.

• Click Next.
• Give the report a name.
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Important: The previous dialogue also allows you to create a Static or a Dynamic report. A 
static report retains the data at the time the report was created. A dynamic report is actually 
a  template  for  the  report.  The  data  is  updated  each  time  the  underlying  table  or  query 
changes.

• Check the Static report radio button.
• Click Finish.

Note: The report is a standard Writer document.
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• File » Save Copy As ..... to save the document.
File » Print.

• Click the Close icon in the top right hand corner of the screen to end.

5.5.1.2 Change arrangement  of  data  fields  and headings  within  a report 
layout.

• Edit the column headings as you would any text in an ordinary document.
In the following screen, the  field name Country  has been changed to an ordinary text 
heading State.

Columns can be moved as follows: 
• Position the cursor in the State column of the report.
• Table » Insert » Columns » After.
• Position the cursor in the Birth Rate column.
• Table » Select » Columns.
• Edit » Cut.
• Position the cursor in the new blank column.
•  Edit »  Paste.
• Position the cursor in the blank column.
• Table » Delete » Columns.
• Readjust the column widths.
• File » Close.

5.5.1.3 Group data under a specific heading (field) in a report in 
ascending, descending order.

• Edit the  People  table to include an additional field called  Region as shown on the next 
screen.
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• Close and accept the changes.
• Add a region for each record as shown on 

the adjacent screen.
• Close and accept changes.

• Click on Reports in the Database pane.
• Click Use Wizard to Create New Report.
• Following the following screens.
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When you get to the Grouping dialogue, group by Region.

• Click Next.
• Sort by Region is already selected. Add Sort by Country.

This will sort countries alphabetically within each region.

• Click Next.
• Complete the report creation as before and give it the title Populations by Region.

If you used the default layout, the report would appear as follows:
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5.5.1.4 Present specific fields in a grouped report by sum, minimum, 
maximum, average, count, at appropriate break points.

At present, this cannot be done in Base.

5.5.1.5 Add, modify text in Headers, Footers in a report.

• Right click on the African Populations report.
• Click Edit.
• Edit the report header as shown in the next two screens.

• Scroll  down to the bottom of the screen and centre the page numbering in the  report 
footer as shown on the next screen.
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• File » Save.

5.5.1.6 Delete a report.

• Click Reports in the Database pane.
• Click on the report you wish to delete.
• Press Del.
• Confirm the deletion.

5.5.1.7 Save and close a report.

This was covered in section 5.5.1.1.

___________________________________________________________________________
Page 5.72



5.5 OpenOffice.org Base: Reports
_______________________________________________________________________________________________

Module 5: OpenOffice.org Base

Section 6: Prepare Outputs

_________________________________

___________________________________________________________________________
Page 5.73



5.6 OpenOffice.org Base: Prepare Outputs
_______________________________________________________________________________________________

5.6 Prepare Outputs

5.6.1 Prepare to Print

5.6.1.1 Preview a table, form, report.

• View » Preview.
The current table, query, form or report will be displayed in a preview pane.

• Click on a different object and it will be previewed.

• To close Preview mode: View » Preview.

Forms and reports can be previewed in addition as follows.

• Open any form or report for viewing
• File » Page Preview.
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• Click the Close icon in the top right hand corner when done.

5.6.1.2 Change report orientation: portrait, landscape. Change paper size.

• Open the report for editing.
• File » Pinter Settings » Properties.
• Click the Layout tab.
• Set the orientation to portrait or 

landscape.

• Click Advanced.
• Set the paper size.
• Click OK.
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The orientation of the report can also be set 
during stage 5 of the creation process. The 
default layout is landscape.

5.6.2 Print Options

5.6.2.1 Print a page, selected record(s), complete table.

This option is not available in Base.

5.6.2.2 Print all records using form layout, specific pages using form layout.

• Open a form for viewing.
• File » Print.
• in Print range, either

Click All to print all records
OR
Click Pages and inserted a range such as 
3-7 or insert a list separated by commas 
such as 3,5,6,9

• Click OK.

When a form is displayed, only the current page can be printed. This is done using the File » 
Print command.

5.6.2.3 Print the result of a query.

This option is not available in Base.

5.6.2.4 Print specific page(s) in a report, complete report.

The process of printing an entire report or a range of pages is identical to that described in 
5.6.2.2 for printing all records or a range of records in form view.
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