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Syllabus

Module 3: Word Processing

3.1 Using the Application
3.1.I First Steps with Word Processing
3.1.1.1 Open (and close) a word processing application. 
3.1.1.2 Open one, several documents. 
3.1.1.3 Create a new document (based on default, other available template). 
3.1.1.4 Save a document to a location on a drive.
3.1.1.5 Save a document under another name. 
3.1.1.6 Save a document in another file type such as: text file, Rich Text Format, 

HTML, template, software specific file extension, version number.
3.1.1.7 Switch between open documents.
3.1.1.8 Use available Help functions.
3.1.1.9 Close a document. 
3.1.2 Adjust Settings
3.1.2.1 Change between page view modes. 
3.1.2.2 Use magnification/zoom tools. 
3.1.2.3 Display, hide built-in toolbars. 
3.1.2.4 Display, hide non-printing characters.
3.1.2.5 Modify basic options/preferences in the application: user name, default 

directory/folder to open, save documents.

3.2 Main Operations
3.2.1 Insert Data
3.2.1.1 Insert text.
3.2.1.2 Insert special characters, symbols. 
3.2.2 Select Data
3.2.2.1 Select character, word, line, sentence, paragraph, entire body text.
3.2.3 Edit Data
3.2.3.1 Edit content by inserting new characters, words within existing text, 

over-typing to replace existing text.
3.2.3.2 Use the undo, redo command. 
3.2.4 Duplicate, Move, Delete
3.2.4.1 Duplicate text within a document, between open documents. 
3.2.4.2 Move text within a document, between open documents.
3.2.4.3 Delete text. 
3.2.5 Search and Replace
3.2.5.1 Use the search command for a specific word, phrase. 
3.2.5.2 Use a simple replace command for a specific word, phrase. 

3.3 Formatting
3.3.1 Text Formatting
3.3.1.1 Change text appearance: font sizes, font types. 
3.3.1.2 Apply text formatting such as: bold, italic, underline. 
3.3.1.3 Apply subscript, superscript to text.
3.3.1.4 Apply case changes to text.
3.3.1.5 Apply different colours to text.
3.3.1.6 Copy formatting from a piece of text to another piece of text.
3.3.1.7 Apply an existing style to a word, a line, a paragraph.
3.3.1.8 Use automatic hyphenation. 
3.3.2 Paragraph Formatting
3.3.2.1 Insert, remove paragraph marks. 
3.3.2.2 Insert, remove soft carriage return (line break) marks.
3.3.2.3 Align text left, centre, right, justified. 
3.3.2.4 Indent paragraphs: left, right, first line, hanging.
3.3.2.5 Apply single, double line spacing within paragraphs. 



3.3.2.6 Apply spacing above, below paragraphs.
3.3.2.7 Set, remove and use tabs: left, centre, right, decimal. 
3.3.2.8 Apply bullets, numbers to a single level list. Remove bullets, numbers from a 

single level list.
3.3.2.9 Change between the style of bullets, numbers in a single level list from 

built-in standard options.
3.3.2.10 Add a top and bottom border, box border and shading to a paragraph.
3.3.3 Document Formatting
3.3.3.1 Change document orientation, portrait, landscape. Change paper size.
3.3.3.2 Change margins of entire document, top, bottom, left, right.
3.3.3.3 Insert, delete a page break in a document.
3.3.3.4 Add, modify text in Headers, Footers. 
3.3.3.5 Add fields in Headers, Footers: date, page number information, file location. 
3.3.3.6 Apply automatic page numbering to a document.

3.4 Objects
3.4.1 Tables
3.4.1.1 Create a table ready for text insertion.
3.4.1.2 Insert, edit data in a table.
3.4.1.3 Select rows, columns, cells, entire table.
3.4.1.4 Insert, delete, rows and columns.
3.4.1.5 Modify column width, row height.
3.4.1.6 Modify cell border width, style, colour.
3.4.1.7 Add shading to cells.
3.4.2 Pictures, Images, Charts
3.4.2.1 Insert a picture, an image, a chart into a document. 
3.4.2.2 Select a picture, image, chart in a document.
3.4.2.3 Duplicate a picture, image, chart within a document, between open 

documents.
3.4.2.4 Move a picture, image, chart within a document, to another document.
3.4.2.5 Resize a picture, image, chart. 
3.4.2.6 Delete a picture, image, chart.

3.5 Mail Merge
3.5.1 Concept and Practice
3.5.1.1 Understand the term mail merge and the concept of merging a data source 

with a main document such as a letter or a label document.
3.5.1.2 Open, prepare a main document for a mail merge by inserting data fields.
3.5.1.3 Open, prepare a mailing list, other data file, for use in a mail merge.
3.5.1.4 Merge a mailing list with a letter, label document.

3.6 Prepare Outputs
3.6.1 Preparation
3.6.1.1 Understand the importance of proofing your document such as: checking 

the layout, presentation (margins, appropriate font sizes and formats) and 
spelling. 

3.6.1.2 Spell-check a document and make changes such as correcting spelling 
errors, deleting repeated words.

3.6.1.3 Add words to a built-in custom dictionary.
3.6.1.4 Preview a document.
3.6.2 Printing
3.6.2.1 Choose print output options such as: entire document, specific pages, number 

of copies.
3.6.2.2 Print a document from an installed printer using defined options, default 

settings.
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3.1 OpenOffice.org Writer: Using the Application
_______________________________________________________________________________________________

3.1.1 First Steps with Word Processing

3.1.1.1 Open (and close) a word processing application

For the most part, using Writer in either Windows or Linux is the same. The major difference 
occurs in open and closing the application. The other variation is in opening and saving files as 
the file system is quite different in Windows and Linux.

Open Writer in Linux

• Click on Start Applications
• Click Office
• Click Word processors
• Click OpenOffice.org Writer

As there are many variations in the way Linux may be installed on computers, it is possible that 
there will  be some variation.  The above method is  the default  when OpenOffice.org 1.1.0 is 
installed as part of the Mandrake 9.2 distribution and KDE 3.1 is used as the desktop. Mandrake 
9.2 is in turn based largely on the Red Hat distribution.

Open Writer in Windows

• Click the Start button.
• Click Programs.
• Click OpenOffice.org 2.0
• Click OpenOffice.org Writer

The Writer screen will now display. The components of the screen are shown below.

Menu bar Vertical Scrollbar Ruler Standard toolbar

Font type Font size Work area

_____________________________________________________________________________
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Convention

Because we will be making extensive use of the Menu bar, we will make use of the following 
convention in using the functions of the menu bar.

• File » Save.

Will mean exactly the same as

• Click File on the Menu bar.
• Click the Save option in the menu.

Close Writer

• File » Exit.

This will close all open documents and exit Writer. 
If  you  have  made  any  modifications  to  open 
documents, Writer will  ask you whether you wish 
to save or discard the changes you have made. It 
will also give you the option of canceling the Exit 
operation.

                                 
3.1.1.2 Open one, several documents

One of the advantages that word processors such as Writer provides for us is the facility to save 
our work and recall it at a later time. We can then print our work or make further changes (edit). 
In addition, we are able to create many versions of the same document, each of which can be 
saved on our hard drive under an appropriate name.

To open a document:

• File » Open.

At this stage there is a difference between what will happen in Linux and Windows.

Linux:

The Open dialogue will appear. In general, this 
will point to your home directory. 

In this case, the  Open dialogue is  pointing to 
the directory /home/david.

• If  necessary,  navigate  to  the  desired 
directory.

• Highlight the file you wish to open.
• Click Open.

_____________________________________________________________________________
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If you wish to open a file contained on your floppy, navigate to the directory /mnt/floppy.

On the top right of the Open dialogue, there are three important icons:

Up one level: Pressing this icon will move you to the parent of the current directory.

Create new directory: This option allows you to create a new directory in the current 
directory. In order to be able to do so, you will need the appropriate user rights.
Default directory: Pressing this icon will  move you to the default  directory. This is 
useful if you have moved through several directories and wish to return to your starting 
point in the directory tree. This will be different for each user.

Windows XP:

If  you  are  running  Writer  under 
Windows, the Windows Open dialogue 
will be displayed.

If you click in the  Look in window, a 
drop down box will display your current 
directory and available drives. You can 
switch  to  another  drive  by  double 
clicking on it  in this window. You can 
also use the navigation icons to move 
around your directory structure.

• If necessary, navigate to the desired 
directory.

• Highlight the file you wish to open.
• Click Open.

If you wish to open a file on your 
floppy disk, first double click on 
Floppy A: in the Look in  window.

The first two icons in the Open dialogue are the same as under Linux.

The third icon allows you to display the contents of the Open dialogue 
in a number of ways as shown on the adjacent screen.

The  Details option displays important information such as file type, 
size, created or last edited and attributes.

Terminology

We will use the terms document and file interchangeably. Document is the more commonly used 
term when working with Windows while file tends to be used more commonly when working with 
Linux.

Open multiple documents

You may open several documents at the same time. Simply repeat the process described above.

_____________________________________________________________________________
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Although the files will all be open, only one will be displayed on your screen for editing. We will 
refer to this as the active document. In section 3.1.1.7, you will learn how to switch between 
open documents. 

3.1.1.3 Create a new document (based on default, other available template)

To create a new document from scratch:

• File » New » Text document.

This will display a blank screen in which you can create a document. This document will be based 
on default settings. Default settings are ones which Writer sets up for you automatically.

Templates

Templates  are  predefined  layouts  for  creating  documents. 
Writer  has  a  number  of  templates.  It  also  allows  you  to 
create your own templates.

When you select File » New, a number of Writer templates 
are displayed. 

For example, to create business cards:

• File » New » Business cards.

This will then display a dialogue which will make the process 
of creating business cards much simpler than it would have 
been without the use of a template.

To create a document based on a template you have created you would use:

• File » New » Templates and documents.

This will bring up a dialogue which will allow you to select either a predefined Writer template or 
one that you have created. This template will  provide you with the basic format of your new 
document. There is more information on templates in section 3.1.1.6.

3.1.1.4 Save a document to a location on a drive

When you work with a document on your computer, the working form resides in the computer's 
RAM. This is temporary memory used for your current activities. Since RAM is volatile, when the 
computer is switched off, everything that is in RAM is automatically lost. In order to keep your 
work you will  need to transfer the contents of RAM to your hard disk. This process is  called 
saving.

When you save a document, you give it a name and you specify where it is to be stored.

_____________________________________________________________________________
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Save an existing document

If you have opened a document and made some changes, the process of saving it is very simple:

• File » Save.

This will change the contents of the stored version so that it is identical to the version that is 
displayed on your screen. In this case, the previous version on disk is overwritten.

If you use File » Save in a newly created document, Writer will automatically assume that you 
wish to use File » Save as.

Save a new document

When you create a document from scratch, there is no version stored on disk. To save the file to 
disk:

• File » Save as.

Now depending on whether you are using Linux or Windows, slightly different dialogue windows 
will be displayed.

Linux:

The  Save as dialogue will  appear. In general, 
this will point to your home directory. It is very 
similar  in  appearance  and  functionality  to  the 
Open dialogue.

• If  necessary,  navigate  to  the  directory  in 
which you wish to save the file.

• Enter a name into the File name window.
• Click Save.

For the moment we will  not be concerned with 
all the options in the Save as dialogue.

Windows:

The  Save as dialogue window has a very 
similar structure to the Open window.

If  you  click  the  Save  in window,  your 
position  within  your  drive  and  directory 
structure will be displayed.

• If necessary, navigate to the directory in 
which you wish to save the file.

• Enter a name into the File name window.
• Click Save.

For the moment we will  not be concerned 
with  all  the  options  in  the  Save  as 
dialogue.

_____________________________________________________________________________
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3.1.1.5 Save a document under another name

When you use the File » Save function, the contents on disk are overwritten by the contents on 
your screen. It often happens that we don not want to do so. In other words, we might wish to 
keep copies of different versions of the file under different names.

Another possibility is that we wish to keep copies of the same document, but in different places.

In both cases use the File » Save as  function.

Suppose, for example, you are writing a difficult letter to someone. Suppose you initially call the 
letter  LetterToJo. After having made some changes you could use Save as, but this time call 
the document LetterToJo1. The following version could be LetterToJo2, and so on.

3.1.1.6 Save  a  document  in  another  file  type  such  as:  text  file,  Rich  Text 
Format, HTML, template, software specific file extension, version number

File formats

There are many different word processors and applications that can read text documents. One of 
the very important aspects of working with information technology is  the ability  to exchange 
documents between different systems.

Each application has its own way of storing information in electronic form. This is known as the 
format of the application. For example, Microsoft Word stores documents is a different electronic 
format to OpenOffice.org Writer.

Another issue we need to contend with is that as software develops in sophistication, the format 
of the documents will change to cater for the increased sophistication. We also need to be able to 
store a document in a format that could be read by an earlier version of an application package.

There are also a number of generic formats that can be used. These are formats that are not 
specific to a particular application but which have been designed by the information technology 
industry to form a common basis for all documents.

Each format has its own file extension. Sometimes we refer to the format by its extension. For 
example, Writer 1 creates sxw files, Writer 2 creates odt while Microsoft Word creates doc files. 
Rich text format, a generic format, uses the rtf extension.

Web browsers can only read documents created in Hypertext Markup Language or html. 

To save a file in a particular format (the 
method is the same in both Linux and 
Windows):

• File » Save as.
• Click on the Save as type drop down window.
• Select the type.
• Click Save.

Notice that the Save as type window lists both 
formats and versions of formats.

_____________________________________________________________________________
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The following table provides a reference to some common file types.

Format Extension Details

Writer version 1 sxw This is the format in which Writer version 1 saved its 
documents

Writer version 2 odt Open Document Text is the new standard format for version 
2 of Writer.

MS Word doc Writer enables you to save documents in the formats of the 
different versions of MS Word

HTML htm
html

Documents that are meant to be read by web browsers such 
as Internet Explorer and Netscape must be saved in HTML 

format. This is an abbreviation for HyperText Markup 
Language.

Template stw A template is an outline of a document that can be used for 
future documents.  Templates will be covered in more detail 

in a subsequent chapter.

Rich text format rtf This is a format designed for the exchange of formatted text 
files. The main disadvantage is that the format creates 

fairly large files.

Text txt Text files containing unformatted text

Versions As applications develop they include new features. Many of 
these relate to format.

Portable document 
format

pdf This is a particularly important format. If you create a file in 
pdf format, you can send this to other users who can view it 

with the free Adobe Acrobat Reader. They are, however, 
unable to edit it.

Save a file in doc format suitable for Microsoft Word

Since MS Word is very widely used, you may regularly need to save documents in doc format. 
This will allow MS Word users to read your documents.

Create a file in pdf format

• File » Export as PDF.
• Select the directory in which you wish to save the file.
• Enter a file name.
• Click Save.

Templates

Once you have worked with Writer for a while you will  want to create your own templates on 
which to base your documents. Often these templates only contain formatting features such as 
margin settings, page orientation, fonts similar features. They can, however, also contain text. 

You may for example have to create invoices on a regular basis. Invoices have certain formatting 
features, but they also contain a lot of text which is the same on each.

_____________________________________________________________________________
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Create a template

• Create the document you wish to use as a template. This may consist only of formatting or 
formatting and text.

• File » Save as.
• Enter the name of the template into the 

File name window.
• Click on the Save as type window and 

select  Open  Document  Text 
Template as  shown  in  the  adjacent 
window.

• Select the directory in which you wish to store the template.
• Click Save. 

This will save the contents of your workspace in template format with an ott extension.

Although the method of creating templates is the same, you need to take care of where you save 
them so that  you  can  access  the  templates  when  you  need  them.  The  following  are  some 
suggestions.

Saving templates in Linux

In Linux, save your templates in the subdirectory called Documents in your home directory.

Saving templates in Windows

A good place to store templates initially is in My documents.

If you save templates in these directories, you can access them when you create a new document 
as follows:

• File » New » Templates and documents.
• Click My documents.
• Select the template and click Open.

3.1.1.7 Switch between open documents

You may open several documents using the  File » Open  function. You will, however, only be 
able to edit the active document, the one that is displayed on your screen.  To make another 
document active, you need to switch to that document.

• Click Window on the menu bar.

A list  of open documents is  displayed in the 
lower half of the window. The active document 
is marked with a dot.

• Click on the document you wish to switch to.

_____________________________________________________________________________
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3.1.1.8 Use available Help functions                                                                

The help system of OpenOffice.org provides a complete reference to the system.

Contents

• Help » OpenOffice.org Help.

This accesses the help system of OpenOffice.org, not just Writer.

• Click on the Contents tab.

Each book represents a major section.

• Double click on any book icon, for example  Text documents. This will display the contents 
which may be further subsections or actual entries.

• Double click on a subsection, for example Navigating text documents.
• Double click on a entry, for example  Rearranging a Document Using the Navigator. The 

right hand pane will contain a detailed description of the topic.

Index

The Contents tab is the same as the table of contents at the front of the book. This organises 
entries by function.

The Index tab functions in the same way as the index at the back of the book. This provides an 
alphabetic listing of topics.

• Click on the Index tab.

_____________________________________________________________________________
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• Begin typing a term that you are interested in into the Search term window. Type for example 
the word template.

OpenOffice.org will attempt to anticipate what you are searching for. As you type in the Search 
term window, the alphabetic listing of topics will change. The entries are divided into headings 
and actual topics. The headings are flush against the left hand side of the pane while the actual 
topics are slightly indented.

• Double click on an entry.

The right hand pane contains the details of the topic you have selected.

Within the details of the entry you will also see a number of hyperlinks. These are underlined in 
blue. These are references to related topics. To jump to one of these entries, double click the 
hyperlink.

Find

OpenOffice.org  provides  yet  another  method  of  searching  for  information.  Whereas  both 
Contents and  Index are based on an alphabetic listing of topics,  Find allows you to search 
within the text of the entries for topics using a keyword.

Suppose you did not find the previous description of the term hyperlink adequate and you wish 
to find all topics in OpenOffice.org that make reference to this term.

• Click on the Find tab.
• Type the work hyperlink into the Search term window.
• Click Find.
A list of entries that contain the word hyperlink are displayed.

• Double click on the entry that you wish to read.

_____________________________________________________________________________
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The occurrences of the search word are highlighted in the details window.

Print entries in Help

• Click the print icon, .

Create bookmarks

When you read a book you may sometimes turn the corner of a page to mark important pages for 
easy later reference. A bookmark is the electronic equivalent.

• Click the create bookmark icon, , to mark an entry.
• Enter a name for your entry in the Add to bookmarks dialogue.
• Click OK.

Use bookmarks

• Click on the Bookmarks tab.

A list of bookmarks you have created will be displayed.

• Double click on an entry to read the details.

3.1.1.9 Close a document

Although  you  can  have  several  documents  open  at  a  time,  it  is  not  a  good  idea  to  have 
unnecessary documents open as these use up system resources and can slow your machine 
down.  Just  as  important  is  the  fact  that  it  is  just  simply  very  confusing  to  have  to  many 
documents open at once. This is similar to working with a cluttered desk and not putting things 
away when you have finished with them

To close a document:

• File » Close.

If  the version  in  the work area corresponds to  what  is  saved on disk,  Writer  will  close the 
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document immediately. If you have edited the document since it was last saved, Writer will check 
whether or not you wish to save or discard the changes before closing.
 

3.1.2 Adjust Settings

3.1.2.1 Change between page view modes

Full screen

If you wish to work with a document without having the toolbars or scrollbars displayed, use Full 
screen mode. In this mode, the document will be displayed as it will be printed.

• Switch off the ruler using View » Ruler. If you wish to see the ruler in full screen mode, leave 
this step out.

• View » Full screen or press Shift+Ctrl+J (Hold down both the Shift and Ctrl keys and press 
J.)

To return to normal viewing:

• Press the Full screen on/off icon or press Shift+Ctrl+J.
• Switch on the ruler using View » Ruler, if necessary.

Page preview

An alternative method of viewing the document as it will appear in printed form is to use Page 
preview.

• File » PagePreview.

The default display is two pages side by side as on the following screen.

_____________________________________________________________________________
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In Page preview mode, a context sensitive toolbar is displayed.

If you let the cursor hover over the icons, a bubble will be displayed indicating the function of 
each.

• Press the  button on the toolbar to return to normal mode.

• To navigate through the document in Page preview mode, click one of the navigation icons.

The navigation  icons are  .  These represent previous page, next page, start of 
document and end of document.

• Select the number of pages you wish to view using .

The first icon selects two pages side by side while the second allows the display of multiple 
pages.

• To enter full screen mode, press .

You cannot edit a document in Page preview mode, but you can print it by clicking on 

the print icon, .

3.1.2.2 Use magnification/zoom tools

In  Page preview mode, you can change the magnification of the display, by clicking on the 

zoom icons or changing the zoom factor on the toolbar,  .

To change the zoom in Normal mode:

• View » Zoom.
• Set the zoom factor or select Variable and enter 

a % value.
• Click OK.

3.1.2.3 Display, hide built-in toolbars

To view or hide toolbars:

• View » Toolbars.

This will  display a list of toolbars in alphabetic order. The toolbars 
that are ticked are those that are currently displayed. Each of the 
options in the submenu functions as a toggle.

_____________________________________________________________________________
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• To display a hidden toolbar or hide a displayed toolbar, click the appropriate item.

A toggle is a menu item or icon that reverses the current status. For example, if  the 
Function bar is displayed, View » Toolbars » Function Bar will hide it. One the other 
hand, if it is hidden then the same sequence will cause it to be displayed.

3.1.2.4 Display, hide non-printing characters

When you press Enter to mark the end of a paragraph or Tab to jump to a new tab position, 
Writer marks these with a special character. These characters are usually hidden and do not print 
when you print the document. They can be thought of as control characters.

It is often useful to display non-printing characters, particularly when it  is not clear why the 
document is displaying in a particular format. To do so:

• View » Nonprinting Characters or press Ctrl+F10.

This function acts as a toggle, so it is also used to hide the display of non-printing characters.

The following screen shows how the above paragraphs appear on screen when this function is 
active.

3.1.2.5 Modify basic options/preferences in the application: user name,
 default directory / folder to open, save documents

When you start Writer, it makes certain assumptions as to who is creating the documents, where 
you wish to save documents, the language you wish to use. These are the default conditions. 

The basic options are set using:

• Tools » Options.

This will display the  Options dialogue. Since OpenOffice.org is a highly integrated application, 
many of the options will  apply to all the programs in the suite while others are more specific. 
Which type of option is found in which section is clear from their names.
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User data

When Writer creates a document, it stores the name of the creator of the document. It also 
stores other information along with this. To set the default user name:

• Tools » Options.
• Click the + symbol next to OpenOffice.org 

to expand the options.
• Click User data.
• Fill in which ever options you wish.
• Click OK.

File locations

When you open or save a file, Writer will use the location you set in Options as a starting point. 
This will be the path that will be displayed in the Open and Save as dialogues.

To set the default file locations:

• Tools » Options.
• Click the + symbol next to OpenOffice.org to expand the options.
• Click Paths.

This will display the default paths Writer will use for a wide range of options. The following screen 
shows the display when you are using Linux. 
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The following screen shows the display under Windows.

• Double click My documents.

• Navigate to the desired directory / folder in the usual way.
• Click Select when done.

Terminology: The terms directory and folder can be used interchangeably. Linux prefers the 
term directory whereas Windows prefers the term folder.
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Customising OpenOffice.org for local conditions

• Tools » Options
• Expand language settings and click on Languages.

The dialogue allows you to define the Default currency and Default language.

• Adjust the settings as required and click OK.
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3.2.1 Insert Data

3.2.1.1 Insert text

It is assumed that the reader has some basic keyboard skills. The following section summarises 
some of the important points above enter and editing text via the keyboard. As there is some 
variation in the position of keys on different keyboards, the position of the keys is not shown. 

Paragraphs

To end a paragraph and begin a new line, press the Enter key. Pressing the Enter key a second 
time inserts a blank line following the end of the paragraph.

If you press Shift+Enter, you will create a new line but not a new paragraph. Sometimes this is 
referred to as a soft break. The effect appears to be the same as that of pressing  Enter, but 
there is a subtle difference. If you were to use the Format » Paragraph command, Writer would 
treat all text on either side of the soft break as part of the same paragraph. 

The technical meaning of a paragraph in Writer's terminology is therefore slightly different to that 
of ordinary usage.

Deleting text

There are two keys on the keyboard that allow you to delete text. The Del key deletes text under 
the cursor while the Backspace key deletes text to the left of the cursor.

Using the keyboard to navigate around a document

Key Function +Ctrl key

Right/left arrow 
keys

Moves the cursor one character to the 
left or to the right.

Moves the cursor one word to the left or to 
the right.

Up/down arrow 
keys

Moves the cursor up or down one line. (Ctrl+Alt) Moves the current paragraph 
up or down.

Home Moves the cursor to the beginning of 
the current line.

Moves the cursor to the beginning of the 
document.

Home
In a table

Moves the cursor to the beginning of 
the contents in the current cell.

Moves the cursor to the beginning of the 
contents of the current cell. Press again to 
move the cursor to the first cell in the 
table. Press again to move the cursor to 
the beginning of the document.

End Moves the cursor to the end of the 
current line.

Moves the cursor to the end of the 
document

End
In a table

Moves to the end of the contents in 
the current cell.

Moves the cursor to the end of the 
contents of the current cell. Press again to 
move the cursor to the last cell in the 
table. Press again to move the cursor to 
the end of the document.

PgUp Scrolls up one page. Moves the cursor to the header.

PgDn Scroll down one page. Moves the cursor to the footer.
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3.2.1.2 Insert special characters, symbols

The keyboard allows you to enter most of the text you require. Further, there are numerous 
keyboards  available  for  different  languages  that  allow  you  to  enter  the  characters  that  are 
commonly used in those languages. When the operating system is installed, whether Linux or 
Windows, one of the things that has to be defined is the language of the keyboard.

Whatever keyboard you are using, Writer allows you to enter hundreds of other characters and 
special symbols not available on the keyboard.

Enter a special character or symbol

• Position the cursor at the point where you wish to insert the special character or symbol.
• Insert » Special character.

• Select the Subset to locate the character you wish to insert.
• Highlight the character and press OK.

3.2.2 Select Data

3.2.2.1 Select character, word, line, sentence, paragraph, entire body text

We are able to perform operations such as copying, deleting and formatting on entire blocks of 
text. However, before we can do so we need to select the text we wish to operate on. Usually we 
refer to this as highlighting the text.

Shift +  direction keys or dragging using the mouse

One way of highlighting text, is to position the cursor at the start or end of the text you wish to 
highlight and, while holding down the Shift key, use the navigation keys to move to the other 
end of the text you wish to highlight.

Another related method is  to position the cursor at the start or end of the text you wish to 
highlight and, while holding down the left mouse button, use the mouse to position the cursor at 
the other end of the block of text.
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Selecting text with keyboard combinations and mouse actions

Writer uses certain keyboard combinations and mouse actions to select clearly defined blocks of 
text such as words and paragraphs. These are shown in the following table.

To select Action

A word Double click on the word

To the end of the current line Shift + End

To the start of the current line Shift + Home

Current line Triple click on any word in the line

Paragraph Click at the start of the paragraph, hold down the Shift 
key and click at the end of the paragraph.

Any block of text Click at the start of the block, hold down the Shift key 
and click at the end of the block.

Sentence Click at the start of the sentence, hold down the Shift 
key and click at the end of the sentence.

To the end of the document Shift + Ctrl + End

To the start of the document Shift + Ctrl + Home

Entire document Ctrl+A

3.2.3 Edit Data

3.2.3.1 Edit content by inserting new characters, words within existing text,
 over-typing to replace existing text

Insert and overwrite mode

When working with Writer there are two different modes of text entry,  insert and  overwrite 
mode.  When you are  in  insert mode and you begin  typing,  text  is  inserted at  the current 
position. All text ahead of the cursor is simply pushed further to the right to make way for the 
new text. In overwrite mode text you type replaces existing text.

The Insert key on the keyboard acts as a toggle switching Writer between the two modes. The 
current mode is indicated on the status bar at the bottom of the screen.

The status bar below indicates that Writer is in Insert mode.

If we press the Insert or  INS key, the status bar will change to indicate that you are now in 
overwrite mode.

_____________________________________________________________________________
Page 3.26



3.2 OpenOffice.org Writer: Main Operations
_______________________________________________________________________________________________

3.2.3.2 Use the undo, redo command

When we execute a command on some text, for example delete the text, we are able to reverse 
what we have done. This is known as the undo function. It is also possible after having undone 
the change, get it back. This is called the redo function.

Writer actually keeps a history of recent changes you have made.

Undo

Pressing  Ctrl+Z undoes the last change you made. Pressing it a second time, undoes the one 
before that, and so on. 

An alternative method is to use Edit » Undo. When you use this method, the menu will indicate 
what type of operation you will be undoing.

For  example,  the  adjacent  screen  segment 
shows that the last operation was the creation 
of a new paragraph. The undo will remove this 
new paragraph.

Yet another way of carrying out undo is to press the undo icon on the function bar,  .

Redo

As mentioned above, redo undoes the action of the last undo.

To use this function use Edit » Redo. As in the case of undo, the menu will indicate the action 
that you will be redoing.

You can also execute the redo function by pressing the redo icon on the function bar, .

3.2.4 Duplicate, Move, Delete

3.2.4.1 Duplicate text within a document, between open documents

To duplicate text either within the same document or between two different documents is a two 
stage process, copy then paste. This is accomplished as follows:

Duplicate text within a document

• Highlight the text you wish to duplicate.
• Edit » Copy.
• Position the cursor at the point you wish to duplicate the text.
• Edit » Paste.

If you wish to make another copy of the text, you only need to perform the last two steps since 
Writer remembers the text that you copied.

Duplicate text between documents

The process is basically the same when copying between documents.
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• Highlight the text you wish to duplicate in the first document.
• Edit » Copy.
• Open the second document if it is not yet open or switch to it using the Window menu item.
• Position the cursor at the point you wish to duplicate the text in the second.
• Edit » Paste.

3.2.4.2 Move text within a document, between open documents

To move text either within the same document or between two different documents is a two 
stage process, cut then paste. This is accomplished as follows:

Move text within a document

• Highlight the text you wish to duplicate.
• Edit » Cut.
• Position the cursor at the point you wish to insert the text.
• Edit » Paste.

Move text between documents

The process is basically the same when moving between documents.

• Highlight the text you wish to duplicate in the first document.
• Edit » Cut.
• Open the second document if it is not yet open or switch to it using the Window menu item.
• Position the cursor at the point you wish to insert the text in the second.
• Edit » Paste.

3.2.4.3 Delete text

One method of deleting  a block of text  is  to use the first  two steps of  the move operation 
described above. This will retain a copy of the text that was deleted.

The other method is to highlight the text and press the Del key.

3.2.5 Search and Replace

3.2.5.1 Use the search command for a specific word, phrase

Complex documents can become very large. Often we need to find text within a document but do 
not know where it  is located. Hence the ordinary navigation features are not suitable. Writer 
provides a very important feature for the purpose, namely the search or find feature.

• Edit » Find & Replace or Ctrl+F.
• Click on More Options.

This will display the following dialogue window:
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• Enter the text you wish to search for in the Search for window. This can be a part of a word, a 
whole word or a phrase.

• If you are looking for this word specifically and not as part of other words, tick the  Whole 
words only check box. Otherwise leave it blank.

• If you wish to find only occurrences that are not only the same letters but the same letters and 
case, tick the Match case check box. Otherwise leave it blank.

• You may search backwards from your current cursor position by ticking the Backwards check 
box.

You now have two options.

Find all

• Click Find all to highlight all occurrences of the search text.
• Click Close. All the occurrences will be highlighted. 
• Scroll through the document.
• Press Esc when you are done.

Find

• Click Find to locate the next occurrence.
• Writer will jump to the next occurrence of the search text.
• Click Find again to jump to the next occurrence.
• You may change any Options you as work.
• Click Close when you are done.
• The last occurrence will remain highlighted.
• Press Esc when done to remove the highlighting.

3.2.5.2 Use a simple replace command for a specific word, phrase

The same dialogue allows us to change either all or specific occurrences of a word, phrase or text 
to something else.

Suppose we have some text in which the word “show” occurs a number of times. We wish to 
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replace this with the word “exhibit”.

• Edit » Find and Replace or Ctrl+F.
• Enter the word you wish to replace in the Search for window.

• Tick Backwards if you wish to replace text from the current position backwards. Leave it blank 
to replace in a forward direction.

Global replacement

• Click Replace all. This will replace all occurrences without any further interaction. A window 
will be displayed indicating how many changes were made.

Undo the global replacement

• Edit » Undo. If you execute this command immediately after the replacement, Writer will 
indicate that the last operation was a replacement in the menu. The action of the command 
will be to restore the workspace to its state prior to the replacement.

Selective replacement

• Click Find. This will locate the first occurrence.
• If  you  wish  to  change  this  occurrence,  click  Replace.  Writer  will  then  jump  to  the  next 

occurrence. Otherwise, click Find to skip without making any change.
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3.3.1 Text Formatting

3.3.1.1 Change text appearance: font sizes, font types

Fonts

The term font refers to the style of the type face. Here are some examples:

Arial This is an example of the typeface called Arial.

Verdana This is an example of the typeface called Verdana.

Tahoma This is an example of the typeface called Tahoma.

Times New Roman This is an example of the typeface called Times New Roman.

Comic Sans This is an example of the typeface called Comic Sans.

Bookman Old Style This is an example of the typeface called Bookman Old Style.

Franklin  Gothic 
Medium

This is an example of the font called Franklin Gothic Medium.

The size of fonts is measured in points. A point is 1/72”. The size is determined by the distance 
from the bottom of the descender to the top of the ascender.

Ascender

yt 

Descender 

The  central  part  of  the  letter  is  called  the  body.  Fonts  vary  in  the  relative  sizes  of  their 
ascenders, descenders and body as well as their thickness.

Another difference between fonts are those which have small tails or feet attached to the vertical 
strokes. These are called serif fonts. Examples are Times New Roman and Bookman Old Style. 
The fonts without these are called sans serif fonts. Examples are Arial, Tahoma and Verdana.

Default fonts

The default font is the font that Writer chooses for you unless you specify otherwise. To set the 
default font:

• Tools » Options
• Expand Text document
• Double click on Basic fonts.
• Click on Default.
• Select the font from the drop down window.
• Click OK.

This is shown in the following screen. If you click Default in this dialogue, the fonts will be set to 
the original Writer defaults.
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Use fonts when typing new text

The current font style and size are shown on the object bar as in the following example where the 
font is Arial 11 point.

Any text you type will automatically assume this font.

Change fonts of existing text

You may change the font type and size of existing text as follows:

• Highlight the text you wish to change.
• Click on the font drop down window to display the available fonts and select a font.
• Click on the size drop down window to select a font size. As you complete these operations the 

text in your document will assume the new font immediately.

Undo the changes

• Edit » Undo or Ctrl+Z will undo the changes you have just made.

Available fonts

The fonts that are displayed could vary from installation to installation. Certain fonts are installed 
when you install the operating system, whether Linux or Windows. Further fonts can be added at 
a later stage, but this must be done through the operating system interface.

3.3.1.2 Apply text formatting such as: bold, italic, underline

Attributes

Changes we make to fonts are called attribute changes. Examples include bold, underlining and 
italics. Further, we can add combinations of these as shown in the following table.
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This is ordinary text.   This is underlined text.
This is italic text.   This is underlined italic text.

This is bold text.   This is bold italic text.   This is bold italic underlined text.

Attributes can be set before new text is typed or they can be added to existing 
text. The object bar contains icons for setting bold, italic and underlined.

When an attribute is set, the corresponding icon on the object bar will have a border around it. In 
the above illustration, bold is on but italic and underline are off.

Set attributes for new text

Each of the attribute icons on the object bar acts as a toggle. If the attribute is on, clicking the 
icon will switch it off. If the attribute is off, clicking the icon will switch it on.

• Before  typing  new  text,  set  each  of  the  attribute  settings  using  the  object  bar  icons  as 
described above. These settings will hold for further text until you change them.

Note: If you now move to another part of your document where the settings were set previously, 
the icons on the object bar will change to reflect the settings of this text.

Change attributes of existing text

• Highlight the text whose attributes you wish to change.
• Click on the appropriate icons on the object bar to change the attributes.

Where you highlight text that contains a mixture of the same attribute, for example, some bold 
and some unbold text, the situation becomes slightly more complicated. You will need to click the 
icon two or three times to achieve the desired state.

3.3.1.3 Apply subscript, superscript to text

Superscript and subscript refers to text, usually in a small font, slightly above or below the body 
of existing text. The following table illustrates superscript and subscript.

a2 – 2ab + b2 = (a – b)2

Area of house is 129 m2
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H2SO4 + Cu => CuSO4 + H2

The term position is used to describe the three options of subscript, superscript and normal.

Create new text in superscript or subscript

The quick way of creating superscripts or subscripts is to use the keyboard shortcuts:

• Type your normal text.
• When you wish to start text in superscript, press Shift+Ctrl+P and type the superscript.
• Press Shift+Ctrl+P a second time to revert to normal text.
• Type your normal text, then press Shift+Ctrl+B and type the subscript.
• Press Shift+Ctrl+B a second time to revert to normal text.

Convert existing text to superscript or subscript

• Highlight the text you wish to convert to superscript or subscript.
• Press Shift+Ctrl+P to covert the highlighted text to superscript or  Shift+Ctrl+B to convert 

the text to subscript.

Use the Format menu

• Highlight the text you wish to convert to superscript or subscript.
• Format » Character.
• Click the Position tab.
• Under Position, select either Normal, Superscript or Subscript.

Use icons

If you use superscript and subscript frequently, you might like to add appropriate icons to the 
object bar.

The toolbar can be customised as follows:

• Tools » Customize.
• Click the Toolbars tab.
• Click on the Toolbar drop down window and select Formatting.
• In the Toolbar content window, tick the Superscript and subscript check boxes as shown 

on the following screen.
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• Press OK.

The superscript and subscript icons will be added to the object bar as shown 
below. Instead of using the keyboard combinations, you can now use these 
icons in the same way that you use bold, italic and underline icons.

3.3.1.4 Apply case changes to text

Once you have typed a block of text you are able to change its case. You may, for example, wish 
to convert a block of text to upper case (capital letters).

• Highlight the text you wish to convert.
• Format » Case / Characters.
• Select either  Uppercase or  Lowercase as 

needed.

3.3.1.5 Apply different colours to text

The colour of text can be changed just like the other attributes.

• Format » Character.
• Click the Font effects tab.
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• Click on the Font color drop down 
window to display the available 
colours.

• Select the colour you wish to apply to 
the text.

• Click OK.

As in the case of the other text 
attributes, you can set the colour of new 
text before you type it or change the 
colour of existing text. In the latter 
case, first highlight the text and then 
use this procedure.

You may also change the font colour by using a long click on the Font 
colour icon on the object bar (Hold the left mouse button down until 
the colour palette is displayed). 

3.3.1.6 Copy formatting from a piece of text to another 
piece of text

Suppose you have written quite a long document. During a final 
editing you decide to change the formatting of certain key paragraphs. 
This could involve, font type, size, colour and other attributes. The 
long method would be to repeat the formatting procedure manually on 
each paragraph.

Styles

The more elegant and efficient method would be to format one paragraph very carefully and then 
copy the formatting to other paragraphs. In order to achieve this, Writer makes use of styles. A 
style is a set of attributes that can be applied to characters, paragraphs and pages. Each style is 
given a name.

Writer has styles for characters, paragraphs or pages. The next section will look at styles in more 
detail. This section will consider the basic use of the character style to copy formatting from 
one block of text to another. 

A character style is a set of attributes that can be applied to individual letters, numeric digits and 
symbols. The attributes could include font style, size and colour, and bold, italic or underlining.
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Copy formatting using character styles

• Format the block of text that will serve 
as the model.

• Highlight this text.
• Format » Styles and Formatting or 

press F11.
• Click  the  character  styles  icon  (the 

second icon), .
•
• Click Default in the list of styles.

• Click  the  New  style  from  selection 

icon (at the end), .
• Click New Style from Selection.

• Give the new style a name and click OK.
• Click OK.

• Click on the Fill format mode icon (the paint can).
• Drag this over the text whose format you wish to change.
• Click on the Fill format mode icon or press Esc to stop copying the formatting.

3.3.1.7 Apply an existing style to a word, a line, a paragraph

Writer offers the user a number of different styles. The following table provides a brief description 
of the different styles and functions associated with the stylist. This summary is derived from the 
Writer help system.

Paragraph styles: Displays formatting styles for paragraphs. Use paragraph styles to apply 
the  same  formatting,  such  as  font,  numbering,  and  layout  to  the  paragraphs  in  your 
document.

Character styles: Displays formatting styles for characters. Use character styles to 
apply font styles to selected text in a paragraph.

Frame styles: Displays formatting styles for frames. Use frame styles to format 
frame layouts and position.
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Page styles: Displays formatting styles for pages. Use page styles to determine 
page layouts, including the presence of headers and footers.

List  styles: Displays  formatting  styles  for  numbered  and  bulleted  lists.  Use 
numbering styles to format number and bullet characters and to specify indents.

Fill format mode: Applies the selected style to the object or text that you select in 
the document. Click this icon, and then drag a selection in the document to apply the 
style. To exit this mode, click the icon again, or press Esc.

New style from selection: Creates a new style based on the formatting of the 
current paragraph, page, or selection.

Once the new style has been created, you can open the Styles and Formatting option at any 
stage use the  Fill format mode to change the format of text. The following method can be 
applied to a character, a word, a line of text or a much larger block of text.

• Format » Styles and Formatting  or F11.
• Click the Character style icon.
• Click the style you wish to apply.

• Click the Fill format mode icon, .
• Move the mouse pointer to the starting point of the text you wish to format. The mouse pointer 

will have the form of the paint can, .
• Click and drag (hold down the left mouse button) over the text you wish to change.
• Release the left mouse button and repeat on other text you wish to change.
• Press Esc when done.

An alternative method is as follows:

• Highlight the text to which you wish to apply the style. You can use the shortcuts described in 
section 3.2.2.1 to select the text.

• Format » Styles and Formatting  or F11.
• Click the Character style icon.
• Double click the style you wish to apply.

Paragraph styles

Paragraph styles have additional features associated with them. These features, which include 
margins, justification and line spacing, will be covered in detail in the following sections.

Create a paragraph style

Suppose you regularly create a heading which is centred on the page and uses 14 point bold red 
Franklin Gothic Medium. The centring on a page is a feature which applies to paragraphs and not 
to characters. The following example illustrates how to create a paragraph style called  Gothic 
Heading.
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• Format one of the headings according to 
your specification.

• Highlight the heading.
• Format » Styles and Formatting or F11.

• Click Paragraph styles, .

• Click New style from selection, .
• Click New Style from Selection
• Enter a Style name.
• Click OK.

Modify a paragraph style

You can modify the attributes of a paragraph style 
using the Paragraph styles dialogue.

• Format » Styles and Formatting or F11.

• Click Paragraph styles, .
• Right click on the style you wish to modify.
• Select Modify.

This will display the dialogue.

• Make the changes.
• Click OK.

Use a paragraph style

• Click anywhere in the paragraph you wish to format.
• Format » Styles and Formatting or F11.
• Select Paragraph styles.
• Double click on the style you wish to apply.
• Repeat the process for other paragraphs you wish to format.
• Press Esc when you have finished.

3.3.1.8 Use automatic hyphenation

Where a word will not fit at the end of a line, by default it will be moved to the next line. It is 
possible to break longer words up between lines. This can be done using either automatic or 
manual  hyphenation.  Hyphenation  splits  words between syllables  based on OpenOffice.org's 
internal dictionary.

When you make use of automatic hyphenation, Writer does all the work for you. This option 
can be applied to individual paragraphs or to paragraph styles.
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Apply automatic hyphenation to an individual paragraph

• Click anywhere in the paragraph.
• Format » Paragraph.
• Click on the Text flow tab.
• Tick  the  Automatically check  box  in  the 

Hyphenation area.
• Click OK.

The  current  paragraph  will  be  hyphenated 
automatically by Writer.

Apply hyphenation using styles: Modify the style

• Format » Styles and Formatting.
• Select Paragraph styles.
• Right click on the paragraph style you wish to modify.
• Select  Modify in  the  context  sensitive  menu that  is  displayed to  display  the  Paragraph 

styles dialogue. 
• Click on the Text flow tab. This is the same as in the Paragraph dialogue shown above.
• Tick the Automatically check box in the Hyphenation area.
• Click OK.

Apply the style

Whenever you apply a style which has been modify to include automatic hyphenation, Writer will 
automatically hyphenate the paragraph.

As you insert text into or delete text from a paragraph that has automatic hyphenation, Writer 
will adjust the hyphenation to the changes.

Apply styles using the formatting toolbar

The first window on the formatting toolbar contains a list of available styles.

• Click on the paragraph you wish to change.
• Click on the styles window on the formatting toolbar.
• Select the style you desire.
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The paragraph will be formatted immediately to the new style.

3.3.2 Paragraph Formatting

3.3.2.1 Insert, remove paragraph marks

There is a slight technical distinction between the ordinary use of the term paragraph and the 
term as is commonly used. 

Technically, a paragraph is a block if text that is terminated by a  carriage return, that is by 
pressing the Enter key. Technically we say that Enter inserts a hard carriage return.

If you press Shift+Enter you can create a new line. This creates a new paragraph in the usual 
sense  it  is  used  in  everyday  language.  Technically  we  say  that  Shift+Enter inserts  a  soft 
carriage return. Writer, however, will treat the new text as part of the existing paragraph. This 
means that if you apply a paragraph style to the first part of the paragraph, Writer will apply it to 
the part after the soft return as well. 

Sometimes the hard carriage return is referred to simply as a  paragraph break and the soft 
carriage return as a line break.

These two keys insert different hidden control characters into the text. 

• Press the non-printing characters icon,  , on the standard toolbar to make these and 
other hidden characters visible.

Once hidden control characters are visible, they can be edited like any other text.

The following paragraph illustrates some text in which non-printing characters have been made 
visible.

The  symbol indicates a paragraph break while  indicates a line break.

In this example, the heading is separated from the first paragraph by two paragraph breaks. The 
first and second paragraphs are technically a single paragraph as they are separated by two line 
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breaks.

Insert a paragraph mark

• Press Enter.

Remove paragraph marks

• Display  non-printing  characters  by  pressing  the  non-printing  characters  icon,  ,  on  the 
standard toolbar.

• To delete a paragraph break either position the cursor in front of the paragraph mark break 
and press Del or to the right of the mark and press Backspace.

• Press  to hide non-printing characters.

3.3.2.2 Insert, remove soft carriage return (line break) marks

Insert a line break mark

When you press Enter, a new paragraph is created beginning with the new line. It can happen 
that you wish to insert a new line without actually creating a new paragraph. In this case you can 
insert  a  line  break.  This  has  the  same appearance  as  a  new paragraph,  but  for  formatting 
purposes the text is treated as a single paragraph. To insert a line break:

• Press Shift+Enter.
OR
• Insert » Manual break ..
• Click the Line break radio button and click OK.

Remove paragraph or line break marks

• Display non-printing  characters by pressing the non-printing  characters icon  ,  ,  on the 
standard toolbar.

• To delete a line break either position the cursor in front of the line break mark break and press 
Del or to the right of the mark and press Backspace.

• Press  to hide non-printing characters.

Remove line breaks automatically from a paragraph

When copying text from another source, it sometimes happens that line breaks are inserted into 
a paragraph. This happens in particular when you copy text from an email client into a word 
processor.

• Tools » Autocorrect.
• On the Options tab, ensure that Combine single line paragraphs if length greater than 

50% is selected. (To change the minimum percentage for the line length, double-click the 
option in the list, and then enter a new percentage.)

• Click OK.
• Select the text from which you wish to remove the line breaks.
• Format » Autoformat » Apply.
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3.3.2.3 Align text left, centre, right, justified

Alignment or justification of text refers to the position of the text with regard to the margins. 
Centred text lies midway between the margins, whereas right justified text is aligned against the 
right hand margin but jagged on the left. The following table illustrates the different forms of 
alignment of text.

Left aligned The international airport, Bole, at Addis Ababa (Addis to aficionados) is modern and 
boasts several duty free shops. The drive into Addis reveals a few modern five storey 
structures, but also, it is strikingly free of litter. Buildings range from the palace ruins, 
the Queen of Sheba’s bath, square wattle and daub homes, two supermarkets to the 
sprawling Merkato market – the largest market in East Africa.

Right aligned The international airport, Bole, at Addis Ababa (Addis to aficionados) is modern and 
boasts several duty free shops. The drive into Addis reveals a few modern five storey 

structures, but also, it is strikingly free of litter. Buildings range from the palace ruins, 
the Queen of Sheba’s bath, square wattle and daub homes, two supermarkets to the 

sprawling Merkato market – the largest market in East Africa.

Centre aligned The international airport, Bole, at Addis Ababa (Addis to aficionados) is modern and 
boasts several duty free shops. The drive into Addis reveals a few modern five storey 
structures, but also, it is strikingly free of litter. Buildings range from the palace ruins, 
the Queen of Sheba’s bath, square wattle and daub homes, two supermarkets to the 

sprawling Merkato market – the largest market in East Africa.

Justified The international airport, Bole, at Addis Ababa (Addis to aficionados) is modern and 
boasts several duty free shops. The drive into Addis reveals a few modern five storey 
structures, but also, it is strikingly free of litter. Buildings range from the palace ruins, 
the Queen of Sheba’s bath, square wattle and daub homes, two supermarkets to the 
sprawling Merkato market – the largest market in East Africa.

Set paragraph alignment

• Click anywhere in the paragraph.
• Press the appropriate alignment icon on the object bar.

The alignment icons are shown in the following table.

Left Right Centre Justify

Set alignment in styles

When creating or modifying a paragraph style, you may set a default associated with that style. 
For example, the default style can be set to include justification as follows:

• Format » Styles and Formatting.
• Select paragraph styles.
• Right click on Default.
• Click Modify.
• Click the Alignment tab.
• Click Justified in the Options area.
• Click OK.

All paragraphs that use the default style will now automatically be justified.
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3.3.2.4 Indent paragraphs: left, right, first line, hanging

Indents refer to the amount of space inserted between the text and the left  and right  hand 
margins. In the case of a first line indent, the first line is indented but not the subsequent lines. 
In the case of  a  hanging indent,  the first  line  is  not  indented while  subsequent  lines  are. 
Indents may be set up before a paragraph is created or applied to existing paragraphs.

The following table illustrates the different types of indent.

Left indent The international airport, Bole, at Addis Ababa (Addis to aficionados) is modern 
and boasts several duty free shops. The drive into Addis reveals a few modern 
five storey structures, but also, it is strikingly free of litter. Buildings range from 
the palace ruins, the Queen of Sheba’s bath, square wattle and daub homes, two 
supermarkets  to  the  sprawling  Merkato  market  –  the  largest  market  in  East 
Africa.

Right indent The international airport, Bole, at Addis Ababa (Addis to aficionados) is modern 
and boasts several duty free shops. The drive into Addis reveals a few modern 
five storey structures, but also, it is strikingly free of litter. Buildings range from 
the palace ruins, the Queen of Sheba’s bath, square wattle and daub homes, two 
supermarkets  to  the  sprawling  Merkato  market  –  the  largest  market  in  East 
Africa.

First line 
indent

The international airport, Bole, at Addis Ababa (Addis to aficionados) is modern 
and boasts several  duty free shops. The drive into Addis reveals a few modern five 
storey structures, but also, it is strikingly free of litter. Buildings range from the palace 
ruins, the Queen of Sheba’s bath, square wattle and daub homes, two supermarkets to 
the sprawling Merkato market – the largest market in East Africa.

Hanging 
indent

The international airport, Bole, at Addis Ababa (Addis to aficionados) is modern and 
boasts several duty free shops. The drive into Addis reveals a few modern five 
storey structures, but also, it is strikingly free of litter. Buildings range from the 
palace ruins, the Queen of Sheba’s bath, square wattle and daub homes, two 
supermarkets  to  the  sprawling  Merkato  market  –  the  largest  market  in  East 
Africa.

Indents are set as follows:

• Format » Paragraph.
• Click the Indents & Spacing tab.
• Set the  Before text,  After text and  First line in the  Indent  area to achieve the desired 

effect.

The following table illustrates how the previous indents were achieved.

Left indent Settings:

Before text = 1.00 cm
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Right indent Settings:

After text = 1.00cm

First line 
indent

Settings:

First line = 1.00 cm

Hanging 
indent

Settings:

Before text = 1.00 cm

First line = -1.00cm

Note: The effect of the 
negative value is to 
move the first line back 
to the margin and so 
create a hanging indent.

If the Automatic check box is ticked, the first line of the paragraph is indented according to the 
size of the font and the line spacing. The setting in the First Line box is ignored.

Set indents in styles

• Format » Styles and Formatting.
• Select Paragraph styles.
• Right click on the style you wish to modify.
• Click Modify.
• Click the Indents & Spacing tab.
• Make adjustments as above.
• Click OK.

All paragraphs based on the style you have modified will change to reflect the new values.

Indents are indicated on the ruler as shown in the next screen.
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Left indent First line indent Right indent

Change indents using the ruler

You may change the indenting of a paragraph by clicking and dragging the three indent markers 
on the ruler.

3.3.2.5 Apply single, double line spacing within paragraphs

The normal spacing between lines of a paragraph is single line. The paragraphs of this book are 
all in single line spacing. In some cases we need to leave more space between lines. Examples 
would include contracts and legal documents.

Change the line spacing of a paragraph

• Format » Paragraph.
• Click on the Indents & Spacing tab.
• Click the Spacing drop drop down window.
• Select the line spacing.
• Click OK.

Change line spacing in a style

• Format » Styles and Formatting.
• Select Paragraph styles.
• Right click on the style you wish to modify.
• Click Modify.
• Click the Indents & Spacing tab.
• Select the line spacing.
• Click OK.

3.3.2.6 Apply spacing above, below paragraphs

Usually Writer does not insert an space above or below a paragraph. Usually users insert a blank 
line at the end of the paragraph to set the paragraph off from other text. This involves pressing 
the Enter key twice. You may, however, let Writer insert this space for you automatically. You 
could also insert space automatically before a paragraph.
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Insert space before or after an existing paragraph
 
• Format » Paragraph.
• Click on the Indents & Spacing tab.
• Adjust the values in the Above paragraph 

and Below paragraph windows.
• Click OK.

Insert space before or after paragraphs in styles

Paragraph styles can be modified to include space before or after paragraphs using the same 
method as shown in previous sections.

3.3.2.7 Set, remove and use tabs: left, centre, right, decimal

Tabs are used for aligning columns of text and numbers. Consider the columns shown on the 
following screen.

The second to fifth columns are left, right, centre and decimal aligned on the tabs respectively. 

Notice the different icons on the ruler for the different tab stops.

Left tab Right tab Centre tab Decimal tab

 
Tab stops are set for a paragraph or group of paragraphs. They may also be set in a style

Set default tab stops

Default tab stops are set in the Default paragraph style.

• Format » Styles and Formatting.
• Select Paragraph styles.
• Right click on Default.
• Select Modify.
• Click on the Tabs tab.
• Click  Delete  all to  clear  existing  tab 

stops.
• Enter  a Position and  click  on  a  tab 

Type.
• Click New.

• Repeat the process for all the default tabs you wish to set.
• Click OK when done.
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Change tab stops on the ruler

You may change the positions of the tab stops on the ruler by dragging them. The change will, 
however, only apply to the current paragraph.

When users create columns of data as in the earlier screen, a common mistake is to press the 
Enter key at the end of each line. This means that when you drag a tab stop icon, it will only 
have an effect on one line. A better idea is to press Shift+Enter at the end of each line until all 
the data has been entered. In this way, Writer can treat the entire block of data as a single 
paragraph. The tab stop icons can then be dragged and change the positions of entire columns at 
once.

Change tab stop settings for a paragraph using the dialogue window

• Format » Paragraph.
• Click the Tabs tab of the dialogue.

If only the default tabs are set, the tab stops will not be shown. If custom tabs have been set, 
these will be displayed as shown in the screen.

Clear all tab stops

• Press the  Delete all button. This will  clear all  default and custom tab stops for the current 
paragraph.

Clear selected custom tab stops

• Highlighted the tab stop you wish to delete and press the Delete button.

Set custom tab stops

• Enter a value into the Position window.
• Select Left, Right, Centered or Justified under Type.
• Press New. The new tab stop will be added to the list of existing tab stops.

A quick way of setting tab stops is to right click on the paragraph, select Paragraph in the 
context sensitive menu and then press the Tabs tab.
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3.3.2.8 Apply bullets, numbers to a single level list. Remove bullets, numbers 
from a single level list

Bullets are useful in emphasising lists of items. The following two screens illustrate the use of 
bullets to emphasise points.

No bullets Bulleted

Bullet an existing list: Quick method

• Highlight the list of items to be bulleted.

• Click the  Bullets icon on the  Formatting toolbar,  .  This will  bullet the list  using the 
default bullet symbol.

Bullet an existing list using Format

• Highlight the list of items to be bulleted.
• Format » Bullets and Numbering.
• Click the Bullets tab.
• Click on the bullet style you wish to insert 

and click OK or simply double click on the 
bullet.

If you press Enter in a bulleted line, Writer will 
automatically insert a bullet at the start of the 
new line.

Bullet a list using Styles

• Highlight the list to be bulleted.
• Format » Styles and Formatting or press F11.
• Click List styles.
• Double click on one of List 1 to List 5.

Sometimes clicking on the bullet icon on the Formatting toolbar produces an undesired spacing 
with the bullet. In such a case, use the Styles and Formatting.

Create a new bullet list

• Insert a bullet at the start of the first line using any of the methods above.
• Press Enter at the end of each line to insert a new bulleted item on the next line.
• Press Enter twice at the end of the final item.
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Turn bullets off

The bullet icon on the Object bar acts as a toggle.

• Select the list from which you wish to remove bullets.

• Click the Bullet icon, , on the Tool bar.

Create a numbered list: Quick method

A numbered list is similar to a bulleted list, except that the items are numbered in sequence. If a 
new item is inserted within the list or at the list, the numbering adjusts automatically.

• Select the list of items to be numbered.

• Click the Numbering icon, , on the Tool bar.

Number a list: Format method

• Select the list of items to be numbered.
• Format » Numbering / Bullets.
• Click the Numbering type tab.
• Double click on the style of numbering you 

wish to apply.

The next screen illustrates two styles of 
numbered list.

Number a list using Styles

• Highlight the list to be bulleted.
• Format » Styles and Formatting or press F11.
• Click List styles.
• Double click on one of Numbering 1 to Numbering 5.

Create a numbered list

The method is exactly the same as creating a bulleted list.
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Remove numbering

• Select the items from which you wish to remove the numbering.
• Click the numbering icon on the Formatting toolbar.

3.3.2.9 Change between the style  of  bullets,  numbers  in  a single  level  list 
from built-in standard options

The style of either numbering or bullets can be changed using the Format menu.

• Select the list to be changed.
• Format » Bullets and Numbering.
• Click the Bullets or Numbering type tab.
• Double click on the new style. The selected bullets or numbering will change immediately.

This same method can be used to convert bullets to numbering or numbering to bullets.

3.3.2.10 Add a top and bottom border, box border and shading to a paragraph

To emphasise points you can add borders to paragraphs. You are able to choose the thickness of 
the border and whether you wish it to have a shadow or not.

To apply a border to a paragraph:

• Highlight the paragraph.
• Format » Paragraph.
• Click the Borders tab.

• Select a line thickness and border style.
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• Select a border colour.

• Select a shadow style. (The first icon is no 
shadow.)

• Select a shadow colour.

• Select a line arrangement.

• Click OK.

This paragraph has a 1.00 pt black border with a grey shadow to the lower left.

3.3.3 Document Formatting

3.3.3.1 Change document orientation to portrait or landscape. 
Change paper size.

Normally we print across the short side of a page as, for example, on the page you are reading. 
This orientation of the page is called  portrait. We can alter the page layout so that we print 
across the long side of the paper. This is called landscape. The next screen illustrates the two 
orientations.

Writer also has to have information about the size of the paper you will be using for printing in 
order to be able to format the document correctly. Usually we use A4 size. There might be times 
when you use smaller paper, such as A5, or larger paper, such as A3. The printer you use will 
impose restrictions on the size of paper. Paper size can be set at the same time as orientation.
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Change orientation and paper size of current page layout

• Format » Page.
• Click the Page tab.

• Click either the Portrait or Landscape radio button to set the desired orientation.
• Set the paper size to a standard size by clicking on the Format drop down window or enter a 

custom size using the Width and Height windows.
• Click OK.

his will set all the pages of the document up to the point where a page break with a new style 
has been inserted. If you wish to use different page orientations within the same document, you 
will need to make use of page styles.

Change the page orientation and paper size in a style

• Format » Styles and Formatting.
• Select Page styles.
• Right click on the style you wish to change and click Modify in the context menu.
• Click the Page tab.
• Set the paper size to a standard size by clicking on the Format drop down window or enter a 

custom size using the Width and Height windows.
• Click either Portrait or Landscape and click OK.

3.3.3.2 Change margins of entire document, top, bottom, left, right

The margins refer to the space at the top, bottom and sides between the printed area and the 
edge of the paper. There is actually a small area around the edge of the paper that cannot be 
printed on. The margins are actually the distance between the printing and the edge of the non-
printable area.
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The margins can be set at the same time as the paper orientation.

• Format » Page.
• Click the Page tab.
• Set  the  Left,  Right,  Top and  Bottom margins  (see the  previous  screen  capture  of  the 

dialogue window).
• Click OK.

The margins can be set in a style in exactly the same way as the paper orientation.

3.3.3.3 Insert, delete a page break in a document

When you reach the end of a page, Writer automatically inserts a page break and puts additional 
text on the following page. This is called an automatic or soft page break. If you insert text on 
a page, Writer will automatically adjust the position of the soft page break.

Insert page break

You may also insert a manual or hard page break at any point where you wish to force Writer 
to end a page. This is done by pressing Ctrl+Enter.

When you insert a hard page break using Ctrl+Enter, Writer will automatically use the current 
page style on the next page.

Delete page break

Display hidden characters by pressing  on the Main toolbar.

• Delete the page break by deleting the  character at the end of the paragraph.

Insert page break and change style

You will often need to change certain features of new pages such as headers, footers, margins 
and orientation. In order to do this you need to make use of styles. You will first need to create a 
style for each set of pages. Once you have your styles defined, you can insert a page break and 
change to a new page style at the same time.

• Insert » Manual break. This will display the adjacent 
dialogue.

• Click the Page break radio button.

• Click on the Style drop down window and select a style for the 
new page.

• Click OK.

You will see how to change headers and footers within a document using styles in the next 
section.
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3.3.3.4 Add, modify text in Headers, Footers

Headers and footers are text that is displayed at the top and bottom of each page. Once the 
header or footer has been defined, Writer will automatically insert it on every page of the current 
style.

Insert a header

• Insert » Header. 

Depending on the existing styles, you will see different menus. The one on the left is what you 
will see in the case of a simple document where there are no styles. The second will be displayed 
where the document contains a number of page styles. 

For the time being, we will assume a situation as on the left.

• Click Default.

This will display a header region. In this you can type and format your heading. You will only 
need to do this once. Writer will automatically insert this header at the top of each page.

• Enter and format the text of the header as shown, for example, on the next screen.

• Click on the body of the page when done.

Insert a footer

Footers are inserted in exactly the same way, except to start the process:

• Insert » Footer.

Change a header within a document

Suppose you are writing a book. At the top of each page you wish to insert the chapter number 
and title.
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First you need to create a style for chapter 1.

• Format » Styles and Formatting.
• Select Page styles. 
• Click Default.
• Click New from Selection.
• Call the style Chapter 1.
• Double click on the Chapter 1 style.
• Insert » Header » Chapter 1.
• Create your header.
• Click Update style and close the Styles and Formatting dialogue.

At this point you would type up the text of chapter 1. When you are ready to start the next 
chapter:

• Make sure the cursor is in Chapter 1. (This will ensure that Chapter 1 is the current style.)
• Format » Styles and Formatting.
• Select Page styles. 
• Click New from Selection.
• Call the style Chapter 2.

At this stage you have created a new style called Chapter 2 which is identical to the Chapter 1 
style.

At the end of chapter 1:

• Insert » Manual break.
• Click the Page radio button.
• Click the Style drop down window and 

select Chapter 2.
• Click OK.

This will insert a hard page break with the new 
page having the Chapter 2 page style.

• Edit the header in chapter 2. This will automatically change the Chapter 2 style.

Change a footer with a document

The process for changing a footer is essentially the same as that for changing the header.

3.3.3.5 Add fields  in  Headers,  Footers:  date,  page number  information,  file 
location

Certain information such as the current page number, date and file information can be added to 
the headers or footers.
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Insert page numbers into headers or footers

• Position the cursor at the point in the header or footer where you wish to insert the page 
number.

• Insert » Fields » Page numbers.

Insert other information into a header or 
footer

Other information such as date, time and 
number of pages can be inserted in exactly the 
same way as shown on the adjacent screen.

Note that the date and time inserted will be 
fixed and will reflect the date and time the 
header or footer was created.

Insert variable date or time into headers 
and footers

To enter a date or time that will reflect the 
current date or time in a header, the process is 
slightly longer.

• Position the cursor at the point in the header 
or footer where you wish to insert the page 
number.

• Insert » Fields » Other.
• Click the Document tab.
• Click Date in Type.
• Click Date in Format.
• Select an appropriate date format in 

Format.
• Click Insert.

A variable time can be inserted in exactly the same way.

Insert a file name and path into a header or footer

The location  of  a  file  can also  be added as a  field to  a  header or  footer.  The file  location 
comprises its file name and path. Either or both can be added as shown on the screen below.

• Position the cursor at the point in the header 
or footer where you wish to insert the page 
number.

• Insert » Fields » Other.
• Click the Document tab.
• Click File name under Type.
• Select the appropriate Format.
• Click Insert.

_____________________________________________________________________________
Page 3.58



3.3 OpenOffice.org Writer: Formatting
_______________________________________________________________________________________________

Insert page numbers with an offset

Normally the first page of the current document starts at 1. You can however add to or subtract 
from this number. The value you add to the page numbering is called the offset. Suppose you 
wish the first page of the current document to start at 10 rather than 1. This means the offset 
must be 9.

• Position the cursor at the point in the header 
or footer where you wish to insert the page 
number.

• Insert » Fields » Other.
• Click the Document tab.
• Click Page under Type.
• Click Page numbers under Select.
• Enter the appropriate value in Offset , for 

example 9.
• Click Insert.

3.3.3.6 Apply automatic page numbering to a document

Automatic page numbering is accomplished by inserting the page number field in either a header 
or footer as described in section 3.3.3.5.
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Module 3: OpenOffice.org Writer

Section 4: Objects

_________________________________
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3.4.1 Tables

3.4.1.1 Create a table ready for text insertion

A table is a grid comprising a number of rows and columns. These may or may not have borders. 
Each cell of the table may contain text or objects such as graphic images and may be formatted 
independently of the other cells.

Insert a table

• Click on the position in the document where you wish to insert the table.
• Insert » Table.

• Writer will call the tables Table 1, Table 2, and so on. You may give the tables a name of your 
own choice. Enter this in the Name window.

• Adjust the Columns spin box to set the number of columns and the Rows spin box to set the 
number of rows.

• Tick the Border check box if you wish to include borders around the cells. Otherwise clear this 
box.

• If you wish to keep the entire table on one page, tick the Don't split table check box. Writer 
will then move the entire table to the following page if it will not fit on the current page.

• Click OK.

The following table was created using three columns and two rows.

• Click in the cell in which you wish to enter text and enter and format the text as usual.
• Click Tab to jump to the next cell or click on another cell to reposition the cursor.
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3.4.1.2 Insert, edit data in a table

Data can be entered into a cell by clicking on the cell and typing in the text in the usual way. 
Formatting is performed as with ordinary text.

If a cell  already contains text, you may click anywhere in the cell  and insert, delete, edit  or 
reformat the text as in the rest of a document.

3.4.1.3 Select rows, columns, cells, entire table

At times we may wish to perform operations on entire rows or columns or the whole table. For 
example, we may wish to change the current font for the entire table. To do this we need to 
select the appropriate row(s) or column(s) or the table itself.

Select entire table

• Position the cursor anywhere in the table.
• If the current cell is empty, press Ctrl+A. Otherwise press Ctrl+A a second time.

The action of  Ctrl+A is somewhat complex. If the cell is not empty, pressing this combination 
selects the current cell. In this case, pressing it a second time selects the entire table. Once the 
table has been selected, pressing Ctrl+A once more causes the entire document to be selected.

Select rows in a table

Writer does not have a single step method for selecting rows or columns. To select a number of 
rows, proceed as follows:

• Go the the start of the first cell of the first row.
• Press Shift+Right arrow repeatedly until all the cells of the first row have been selected.
• Press Shift+Down arrow repeatedly until all the rows have been selected.

Select columns in a table

The method for selecting columns is very similar.

• Go to the start of the first cell f the first column.
• Press Shift+Down arrow repeatedly until the first column has been selected.
• Press Shift+Right arrow repeatedly until all the columns have been selected.

3.4.1.4 Insert, delete, rows and columns

Delete a row

• Position the cursor anywhere in the row to be deleted.

• Table » Delete » Rows or press the Delete row icon on the Table toolbar, .

The table toolbar can be displayed using:

• View » Toolbars » Table
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Delete a column

• Position the cursor anywhere in the column to be deleted.

• Table » Delete » Columns or press the Delete column icon, .

Insert a row

• Position the cursor anywhere in the row adjacent 
to the new row.

• Table » Insert » Rows or press the Insert row 

icon, .
• Adjust the Amount spin window to the number of 

rows you wish to insert.
• Click either the Before or After radio button to 

select whether you wish the new rows to be 
inserted before or after the current row.

• Click OK.

Insert a column

• Position the cursor anywhere in the column 
adjacent to the new column.

• Table » Insert » Columns or press the Insert 

column icon, .
• Adjust the Amount spin window to the number of 

columns you wish to insert.
• Click either the Before or After radio button to 

select whether you wish the new columns to be 
inserted before or after the current column.

• Click OK.

3.4.1.5 Modify column width, row height

When you create a table, Writer uses the default row heights and column widths. The row height 
will be based on the default font and the columns widths will be adjusted to fit equally across the 
page. This is shown on the following screen.

If you change a font, the row height for all the cells will adjust to accommodate the largest font 
on the row as shown on the next screen.
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Row heights

Set the height of rows manually

You may set custom row heights manually as follows:

• Select cells in each of the rows you wish to adjust.
• Right click on one of the highlighted rows in the table, then Row » Height.
• Adjust the value using the Height spin window or typing a value in.

Set optimal row height

Optimal row height is the most appropriate row height based on the size of the fonts used in the 
row.

• Check the Fit to size check box in the Row Height dialogue.

Set row height using the keyboard

• Position the cursor in the row whose height you wish to adjust.
• Hold down the Alt key and press the Up and Down arrows to decrease or increase the height.

Column widths

Set column widths manually

The Format menu option lets you set the width of a single column.

• Select the columns you wish to change.
• Right click in one of the columns, then Column » Width.
• Select the column using the Column spin window.
• Adjust the width of the column using the Width spin window.
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• Click OK.

Set column widths equally

• Select cells in the columns you wish to change.
• Right click in pone of the columns, then Column » Space equally.

Set column width by dragging the border

• Move the cursor over the border of the cell to display the separator icon.
• Hold down the left mouse button. A dotted vertical line will be displayed.
• Hold down the left mouse button and drag the vertical line.

• Release the left mouse button at the desired position.

Set the column width using the keyboard

• Position the cursor in any cell in the column. Hold down the Alt key and press the Left or 
Right arrows. This will also adjust the overall width of the table.

OR
• Position the cursor in any cell in the column. Hold down the Alt+Ctrl keys and press the Left 

or Right arrows. This will not change the overall width of the table.
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3.4.1.6 Modify cell border width, style, colour

By default, Writer will insert and thin, black solid line as the table border. These can be changed 
as follows:

• Click inside the table.
• Table » Table Prpoerties. This will display 

the Table format dialogue.
• Click the Borders tab.
• Select a border thickness and style in the 

Style window.
• Click on the Color window to display a drop 

down list of border colours and select a 
colour.

• You may also may also select a shadow for 
the outer border of the table by selecting the 
appropriate options in the Shadow style 
area of the dialogue. This is covered in the 
next section.

Set the border of individual cells or blocks of cells

The previous description applied to formatting an entire table. You may use the same method to 
set the borders of individual cells or blocks of cells.

• Select the cells whose borders you wish to set.
• Table » Table Properties.
• Click the Borders tab.
• Set the borders as you wish.
• Click OK.

In this case the settings will  only apply to the cells that were selected. The following screen 
illustrates the effect.

In this case the four cells in the heading were highlighted before the command was executed.

3.4.1.7 Add shading to cells

You may insert shading (background) into some or all the cells of the table.

• Select an entire table or a range of cells.
• Table » Table Properties.
• Click the Background tab.
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• Select the colour of the shading.
• Choose whether the shading must be applied to the current selected cells, the current selected 

rows or the entire table.
• Click OK.

Some other important table functions

Merge cells

Suppose we have a situation such as shown on the next screen.

We would like the word TEAM to be centred across the four headings. The solution is to merge 
the four cells and then centre the heading within this new cell.

• Highlight the cells to be merged.

• Table » Merge Cells or click the Merge icon on the Table object bar, .
• Click the Centre icon on the Toolbar.
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Split cells

You may split cells horizontally or vertically.

• Select the cells you wish to split.
• Table »  Split cells or click on the Split 

cells icon .
• Select the number of elements you wish to 

split the cells into.
• Select either Horizontally or Vertically.
• Click OK.

Split table

You may split a table horizontally at the current 
cursor position.

• Click in the table at the point where you 
wish to split it.

• Table » Split table.
• Click No heading.
• Click OK. 

This insert a blank row between the two parts of the table. Each part can now be treated as a 
separate table

Set background colour

The background colour of a table is referred to 
as the fill colour. By default there is no fill. 
This can be changed.

• Click inside the table.
• Table » Table Prpoerties.
• Click the Background tab.
• Select a Background color from the colour 

palette.
• Click on the For drop down window and 

select Cell to apply only to the selected cells 
or Row for the currently selected rows or 
Table if you wish to apply this background 
to the entire table.

• Click OK.
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3.4.2 Pictures, Images, Charts

3.4.2.1 Insert a picture, an image, a chart into a document

Insert picture or image into a document

Although a document consists mostly of ordinary text, you may insert other objects into the text. 
The most common sources of pictures and images are clipart galleries.

• Insert » Picture » From file.
• Browse to the directory / folder contains the graphics.

• Linux: Click the Preview check box:

This is generally a good idea as it helps you 
select an appropriate graphic. Otherwise you 
may just view long lists of file names which 
may not be meaningful.

• Windows: Switch Thumbails on in the 
View menu. 

• Click the graphic you wish to insert and click 
Open or simply double click on the graphic.

This will insert the graphic into the document 
at the current cursor position. 

The following step is very important. 
Usually the graphic can be treated in exactly 
the same way as a text character.

• Click on the graphic to select it. Notice the 
handles around the borders of the graphic. 

• Right click to display the context menu click 
Anchor.

• Click As Character.
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Insert a graphic from the gallery

OpenOffice.org has a built-in set of graphics called the  gallery. You may insert images into a 
document from the gallery.

• Position the cursor at the insertion point.
• Tools » Gallery.
• Select a Theme.
• Select an item in the theme.
• Right click on the item to display a context menu.
• Click Insert then Copy.

• Resize the image.
• Tools » Gallery to close.

Insert a page background from the gallery

You can create textured backgrounds for pages using the gallery.

• Position the cursor at the insertion point.
• Tools » Gallery.
• Select a Backgrounds.
• Select a background.
• Right click on the item to display a context menu.
• Click Insert then Background.

• Click Page if you wish to use the background for the entire page or Paragraph if you wish to 
use it only for the current paragraph.
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Create a chart based on a table

Charts can be created in Writer in the same way that they are created in Calc. Instead of the 
data being found in the rows and columns of a spreadsheet, they will now be found in the rows 
and columns of a table. The following is a detailed example of the creation of a chart in Writer.

• Select the block of cells containing the data. Check whether the first column and first row 
contain labels as in the following screen.

• Insert » Object » Chart.
• Check the appropriate Caption check boxes.

• Click Next.
• Select a Chart type.
• Select whether the Data series is contained in rows or columns. In this case it is in rows.
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• Click Next.
• Choose a Variant of the basic chart type.
• Check the X axis and  Y axis check boxes to display grid lines as desired.

• Click Next.
• Enter Titles for the chart as a whole and for the X and Y axes.
• Tick the Legend check box if you wish to display a legend with the chart. This will indicate the 

meaning of the different colours.
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• Click Create.

Insert a spreadsheet chart in a document

This is covered in the section on duplicating images and charts.
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3.4.2.2 Select a picture, image, chart in a document

Just  as  we  select  text  in  order  to  perform 
actions on it such as delete or copy, we can do 
the same thing with graphics.

• Click anywhere in the graphic to select it.

Notice the handles that are displayed around 
the graphic. These are illustrated in the 
adjacent image.

Once an image has been selected, we are able 
to perform various actions on it.

Just as we select text in order to perform actions on it such as delete or copy, we can do the 
same thing with graphics.

3.4.2.3 Duplicate a picture, image, chart  within a document,  between open 
documents

Images, whether clipart or charts, can be manipulated in the same way. Once the image has 
been selected, it can be duplicated and moved in exactly the same way as ordinary text.

• Select the image or chart that must be copied.

• Edit » Copy or click the Copy icon, , on the Toolbar or press Ctrl+C.
• Position the cursor at the point where you wish to insert the duplicate. This can be within the 

current document or you can switch to another open document.

• Edit » Paste or click the Paste icon,  , on the Toolbar or press Ctrl+V.

A duplicate of the original image will be inserted.

Copy a spreadsheet chart into a document

This method can be used to copy a chart from a spreadsheet into a document.

• Go to the spreadsheet and select the chart you wish to copy into the document.

• Edit » Copy or click the Copy icon, , on the Toolbar or press Ctrl+C.
• Switch to the document.
• Position the cursor at the point where you wish to insert the chart.

• Edit » Paste or click the Paste icon,  , on the Toolbar or press Ctrl+V.

_____________________________________________________________________________
Page 3.74



3.4 OpenOffice.org Writer: Objects
_______________________________________________________________________________________________

A duplicate of the original chart will be inserted into the document.

3.4.2.4 Move a picture, image, chart within a document, to another document

Moving an image is a two step process: Cut then Paste.

• Select the image or chart that must be copied.

• Edit » Cut or click the Cut icon, , on the Toolbar or press Ctrl+X.
• Position the cursor at the point where you wish to move the image. This can be within the 

current document or you can switch to another open document.

• Edit » Paste or click the Paste icon,  , on the Toolbar or press Ctrl+V.

The image will be deleted in its original position and inserted at the new position.

3.4.2.5 Resize a picture, image, chart

When an image is selected, handles are displayed around the borders. By dragging on these, the 
image can be resized.

The four corner handles can be dragged in  any direction.  The handles on the left  and right 
borders can only move horizontally while those on the top and bottom borders can only move 
vertically.

Narrow or widen an object

• Click on either of the side handles.
• Hold down the left mouse button and drag to the left or right.
• Release the mouse button when done.

Lengthen or shorten an object

• Click on either the top of bottom handle.
• Hold down the left mouse button and drag 

up or down.
• Release the mouse button when done.

Change the size in any direction

• Click on a corner handle.
• Hold down the left mouse button and drag in 

any direction.
• Release the mouse button when done.

The adjacent screen shot illustrates dragging 
the bottom corner handles. The image is only 
resized once the mouse button is released.

Alternatively, you can set the actual size of the picture in cm.

• Right click on the picture and select the picture option
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• Click on the Type tab.

This will give you complete control over all the characteristics of the image including its size.

• Check Anchor as character.
This will cause Writer to treat the entire image as though it were an ordinary character. This 
is a very useful setting when inserting images as the image will remain fixed relative to the 
previous character when moving and inserting text.

• Adjust the physical measurements of the image in the Size area of the dialogue.
• Click OK when done.

3.4.2.6 Delete a picture, image, chart

• Select the image.
• Press Del.
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3.5.1 Concept and Practice

3.5.1.1 Understand the term mail merge and the concept of merging a data 
source with a main document such as a letter or a label document

A common situation that arises is that we need to send out the same letter or information to 
hundreds of people or organisations. While the text of the letter may be the same, each will 
contain specific references to the organisation in terms of the address and the person to whom it 
is being addressed.

Another related situation is where we need to print address labels for envelopes to clients. The 
client list may vary from time to time. However, when we need to print labels, we do not want to 
have to type up each one anew.

In situations such as these we can make use of the Mail Merge feature.

Mail merge involves the following:
➢ A template.
➢ A data source.
➢ Merging the data from the data source into the template to create a set of documents.
➢ Printing.

Template document

The template document is an outline of the document that you wish to produce. It contains the 
fixed text which will be the same for all the documents. It also contains place holders for the 
information  that  will  change.  Sometimes  these place holders  are  also  referred to  as  fields. 
Examples would include, name, first name, title, company and address.

Data source

The data source will  contain the data that is inserted into the place holders when the actual 
merging takes place.

In the data source, the data will be organised into a number of rows and columns. Each row is 
called a  record and contains the data that will  be inserted to create a single document. For 
example, each row would contain a name, first name, title and address.

Each record is divided up into fields corresponding to the columns. These contain the individual 
items such as name and first name.

Merging

Merging involves creating the link between the fields in the template and the fields in the data 
source and then the actual creation of the set of documents.

A good way to approach the following sections is to actually create the documents yourself and 
work through the process step by step.
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3.5.1.2 Open, prepare a main document for a mail merge by inserting data 
fields

Create an example of the letter or document you wish to produce

• The first step is to create the document you wish to create.

BLUE MOUNTAIN CHEESE FARM
Hex River Valley

10 January 2004
Ms Yvonne Chadpuri
13 Sea Glen Road
Cape Town

Dear Ms Chadpuri

You are one of our valued customers. We are having a tasting of our new line of cheeses on 
Saturday, 14 February. This will take place in the newly refurbished reception area. We would be 
happy if you could join us on this occasion. You are welcome to bring a partner. RSVP.

Yours sincerely
Jane de Fromage

Create a data source

To illustrate the process you will need to create a simple data source.

• File » New.
• Create the data source such as the one shown below. 
• Ensure there is a comma between each field and a carriage return at the end of the line.

Title,First name,Name,Address 1,Address 2,Code
Ms,Yvonne,Chadpuri,13 Sea Glen Road,Cape Town,8001
Mr,Jacob,de Hague,92 Avon Crescent,Camps bay,8005
Ms,Celia,Ntombi,94 Eastern Road,Tamboerskloof,8001

Note also that the comma is used in this situation as a field separator. Do not be concerned 
that the data file may be quite difficult to read.

• Save the data as a text document. Writer will automatically attach the .txt extension.

The first line of the data source contains the  field names. These will  be used as the place 
holders in the template document. A collection of records such as this is called a table.

The next stage is to prepare the document template. This is the letter or document which will 
be replicated. For each record in the data source a separate document will be created. The field 
names will in each case be replaced by the actual field values of each record.

The following screen illustrates an example of a letter which will  be used as the basis for the 
document template.
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This letter contains specific information for one person. The next step is to replace this with a set 
of field names.

• Highlight Ms in the letter. We will replace this with the field called Title.
• Insert » Fields » Other.
• Click the Database tab.

The next step is to point to the data file. Suppose this file is located in My Documents and is 
called ClientList.

• Click Browse and locate the file.

It will now appear in the list of data sources.

• Click the plus sign to expand the data source. Click the plus sign at the next node.

This will list the fields as shown below.
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• Select Title and click Insert.
• Insert  the same way replace other  specific  information  with  field  names.  Your  document 

template will now appear as on the screen below.

• Click Close.
• Save the document template.
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3.5.1.3 Open, prepare a mailing list, other data file, for use in a mail merge

Use a spreadsheet as a data source

A spreadsheet is a common and useful way of dealing with data. Suppose you have data in a 
Calc spreadsheet. To convert this into a data source, save the file as a csv file. This is illustrated 
in the following screen which shows saving a Calc spreadsheet as a csv file in Windows. 

• In the Save as dialogue, select Text CSV (csv).

Use a table in a document as a data source

Data is commonly supplied in the form of an ordinary document table as shown in the following 
screen.  Equally,  you  may  find  this  a  convenient  way  of  creating  a  data  source.  It  cannot, 
however, be used directly in this format.

Suppose you have a data source such as the following:

Title First name Name Address 1 Address 2 Code

Ms Yvonne Chadpuri 13 Sea Glen Road Cape Town 8001

Mr Jacob de Hague 92 Avon Crescent Camps bay 8005

Ms Celia Ntombi 94 Eastern Road Tamboerskloof 8001

Although this is a very clear way of working with data, you will need to convert it before it can be 
used as an OpenOffice.org data source.

• Click anywhere in the table.
• Table » Convert » Table to text.
• Click the Separate text Other radio button and type a comma in as the separator.
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• Click OK.

This will create a data source which is comma delimited. 

You might find it useful to work with tables when you are creating and editing data. You could 
keep this in one file, for example ClientsTable.txt. When you are ready to use it for merging 
you could  concert it  to  comma delimited form and save this  as another file,  for example 
Clients.txt.

3.5.1.4 Merge a mailing list with a letter, label document

At this stage you should have a document template such as the one shown on the next screen.

• Tools » Mailmerge Wizard.
• Click on each of the stages of the mailmerge wizard. 

Because everything has already been set up, there is little else to do.

• When you get to Edit Document, click the arrows to check that the mailmerge is substituting 
the data in correctly as you wish.

Page 84



3.5 OpenOffice.org Writer: Mail merge
_______________________________________________________________________________________________

Save the merged file

• Check the Saved merged document radio button.

• Click Save Documents.
• Answer the prompts to supply the file names and location in which you wish to store the final 

product.

Print the merged file

You would use the Print merge document option to print without saving a copy of the merged 
document.

Page 85



3.5 OpenOffice.org Writer: Mail merge
_______________________________________________________________________________________________

Creating labels

Labels can be created in exactly the same way as letters. The difference between a mailmerge 
letter and a label is that the label contains only data, such as name and address, and the paper 
size has to match the size of the label. The following description is based on the Writer Help 
system.

• File » New » Labels to open the Labels dialog.

• On the Labels tab, under Format, define the label format.

OpenOffice.org Writer  contains  many formats  of  commercially  available  sheets  for  labels, 
badges, and business cards. You can also add other, user-defined formats.

On the Labels tab, under Inscription, you can choose what you want written on the labels.

This often involves database fields, so that the labels can be printed with varying content, when 
sending "Form Letters" for example. It is also possible to have the same text printed on every 
label. If you have used a spreadsheet or text file for storing the data, the name under which you 
saved it will be both the database and table name. 

Assume that you have a text file called Addresses.txt and the first row contained the headings 
Title, Name, Surname, Address 1, Address 2, Postal Code. First of all, we need Writer to see 
this as a data source.

• Tools » Mailmerge wizard.
• Go to step 3: Insert Address Book
• Click Add.
• Browse to the data source and, when you have highlighted it in the File Explorer window, click 

Open.
This will add the name of the new data source.

• Click OK then Cancel.

• Click on the Database and Table drop down windows and select the name of the datasource.
• Click the Database field drop down window and select a field.
• Press the Insert icon to drop this into the Label text window.
• Separate fields with spaces and carriage returns as needed.
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• Select a standard format for the labels as shown on the screen above.
This will depend on having a format that is supported by Writer. On the Format tab you can 
also define your own label formats, not covered by the predefined formats. To do this, select 
"User" from the Type list box. On the Options tab, you can specify whether all labels or only 
certain ones are to be created.

• Click New Document.
This will create the Template document for the Mailmerge.

• Tools » Mailmerge Wizard.
• Jump to the finale step: Save, Print or Send.
• Select either Saved merged document  or Print merged document.
• Click Save documents.
• Click Finish.
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3.6.1 Preparation

3.6.1.1 Understand  the  importance  of  proofing  your  document  such  as: 
checking the layout, presentation (margins, appropriate font sizes and 
formats) and spelling

With the large number of features available in Writer, there is no reason all documents should 
not  be  finished  to  a  professional  standard.  In  fact,  business  and  industry  require  all 
documentation to be of a professional standard. Anything less will usually be viewed as poor and 
reflect badly on the author.

Here are some of the aspects of documents you should pay attention to.

Fonts

For most writing use a standard font such as Times New Roman, Bookman, Arial, Tahoma or 
Verdana. In most cases, a 10 or 11 point font is most appropriate. Be wary of using fancy fonts in 
business writing.

There is considerable debate as to whether it is better to use serif or sans serif fonts. There has 
been some research that serif fonts such as Times Roman are easier to read. Serif fonts are 
commonly used in books. However, this is still a matter of personal taste.

Do not mix too many fonts. Generally it is best to stick to three sizes of the same font. The more 
a font differs from the font of the body of the text, the less frequently it should be used.

Styles

Make  a  habit  of  defining  and  using  styles.  These  can  help  keep  your  writing  consistent. 
Inconsistency in style within a document looks unprofessional. An example of where styles are 
particularly necessary are section headings such as the one at the start of this section. Not only 
do styles keep your work consistent, they save you the problem of having to define settings from 
scratch each time.

White space

White space refers to the areas of a document where there is no text. White space is found 
between paragraphs, after headings and in margins.

For legibility, it is very important to have the correct amount of space. It is impossible to lay 
down  a  formula.  You  will  need  to  develop  skill  is  looking  at  your  finished  document  and 
considering a number of points:

- Is it pleasing to the eye?
- Is it easy to pick up the main sections?
- Is the use of white space consistent?

Margins

Margins are an example of white space. But they are not concerned purely with appearance. If 
you intend  binding  a document,  you will  need to  endure that  the left  hand margin  is  wide 
enough. If you print on the reverse of each page (back to back), you will need to set wide left 
and right margins on alternate pages.

If you are submitting a document for a specific purpose, such as an academic paper, you might 
be  required  to  set  margins  according  to  a  fixed  specification.  This  might  well  different 
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significantly from the default setting. Check that your margins, and any other aspects, conform 
to external requirements.

Spelling

Spelling mistakes are one of the most serious problems, especially since they are easy to deal 
with. Set Writer up so that spelling is checked as you type. Spelling is dealt with in the next 
section.

Consistency

As mentioned a couple of times above, ensure that your document is consistent in style and 
layout throughout. As you develop experience, your skill at noticing inconsistencies will develop. 
If you are vigilant from the start, this skill  will  develop more quickly. There are unfortunately 
many very experienced users who are very careless in this regard. Sometimes technology can 
make us lazy.

3.6.1.2 Spell-check a document and make changes such as correcting spelling 
errors, deleting repeated words

Writer checks the spelling of words by consulting its dictionaries for the different languages. By 
default, OpenOffice.org uses American English. The spelling of American English differs from that 
of English as used in the United Kingdom or South Africa.

Set languages

You might also create documents in French or German. In all cases you need to be able to set up 
OpenOffice.org to check spellings in the languages you work with.

• Tools » Options.
• Expand Language settings and click on Languages.
• Click on the  Western drop down window and select the default languages you wish to use. 

This will place a tick next to each language you select.
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• Now click Writing Aids.
• Make sure Check in all languages is ticked.

• Click OK.

Check spelling as you type

You can get Writer to check spelling as you type.

• Tools » Spellcheck. 
• Click Options.

• Make sure the Check spelling as you type box is checked.

Alternatively,

• Press  on the Standard toolbar.

This is a toggle function. If the automatic spell check is off, it will switch it on. If it is on, it will 
switch it off. 

As you type, words that Writer cannot find in any of its dictionaries will  be underlined with a 
wavy red line as shown on the next screen
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A common comment of users is that words such as colour are shown as incorrectly spelt even 
though they have selected the English UK dictionary. The reason is usually because they have 
not performed the second step of the previous section, Check in all languages.

Check spelling of document

You may also check the spelling of a document at any stage.

• Tools » AutoSpellcheck or press  on the Standard toolbar.

Spellcheck will start at the current position in the document. When it reaches the end of the 
document, it will  ask you if you wish to continue from the start. When an error is found, the 
following dialogue is displayed.

You have a number of options

Ignore the error

• Click Ignore to ignore only this occurrence or click Always ignore to ignore all occurrences of 
the error.

Correct the error using a suggestion

• Select the alternative in the Suggestions  window.
• Click Replace to replace only this occurrence or press Always replace to replace all 

occurrences of the error.

When you select the latter option, the next time Writer encounters the error, it will not prompt 
you for a reply, but make the change automatically.
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Manually correct the error

You may recognise the spelling is incorrect but there may not be a suitable word in the 
suggestions.

• Edit the contents of the Word window.
• Click Replace.

Spellcheck selected text or a single word

• Highlight the word or block of text.

• Press F7 or press .

Thesaurus

Another very useful writing aid is the thesaurus. This provides you will a list of words related to 
the current word.

Suppose you have used the word big repeatedly. 

• Position the cursor on the word.
• Tools » Language » Thesaurus or Ctrl+F7.
•

• Select  a  word from the  synonym window. The selected word will  appear in  the  Replace 
window.

• Click OK to replace the original word in your document.

3.6.1.3 Add words to a built-in custom dictionary

There are limits to the scope of the built-in dictionaries. In particular, if you use technical terms, 
it is quite likely that OpenOffice.org will identify these as errors. To deal with the specialist needs 
of users, OpenOffice.org allows you to add words to your the user-defined dictionaries.

When OpenOffice.org finds a spelling error, the Spellcheck dialogue is displayed.
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• Click Add if you wish the word to be added to the user-defined dictionaries. 

The word will be added to all active user-defined dictionaries. In future, if any of these are active, 
OpenOffice.org will not detect any error when it encounters the word.

3.6.1.4 Preview a document

Before printing a document, you can view it on-screen as it will appear on the printed page. This 
feature was covered under Page preview in section 3.1.2.1

3.6.2 PRINTING

3.6.2.1 Choose print output options such as: entire document, specific pages, 
number of copies

To print a document,

• File » Print.
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Select print range

• Click the All radio button to print the entire document.
OR
• Click the Pages radio button and enter the range of pages to be printed in the form 11-24. 

Alternatively list the pages you wish to print separated by commas.
OR
• Click the Selection radio button to print a highlighted block of text.

Select number of copies

• Use the Number of copies spin window.
• If you wish the pages to be collated, tick the Collate check box.

Print to a file

This feature is not commonly used anymore, but allows you to direct the output of the printer to 
a file rather than to paper.
• Tick the Print to file check box to enable this feature. In order to complete the operation, you 

will be prompted for a file name. Writer will add a .prn extension to the name.

3.6.2.2 Print  a  document  from  an  installed  printer  using  defined  options, 
default settings

Default conditions are the settings that you are offered by OpenOffice.org. To print a document 
using default settings, you would simply use the sequence:

• File » Print.
• Click OK.

Selecting a printer

In many situations, you are able to print your work on various printers. You need to make a 
selection of the most appropriate printer.

• File » Print.
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• Select a printer in the Name drop down window.
• Adjust Print range and Copies, if necessary.
• Click OK.
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